Omówienie

Exact Audio Copy to program, którego podstawowym zadaniem jest zgrywanie nagrań z płyt audio na twardy dysk komputera. Zastosowane techniki zgrywania dają gwarancję poprawności wyników, a w połączeniu z funkcją AccurateRip - pewność. Dodatkowo wyposażony został w bazę danych, pozwalającą na proste zarządzanie płytoteką oraz w możliwość wypalania płyt audio.

Konfiguracja programu może sprawić pewne kłopoty początkującym, ale przebrnięcie przez nią da wiele satysfakcji i pewność, że kopie nagrań są perfekcyjne i nie zawierają żadnych niepożądanych artefaktów.

Exact Audio Copy został wyposażony w dwa podstawowe tryby zgrywania nagrań: pewny i synchronizowany. Tryby synchronizowane przeznaczone są dla tych, którzy posiadają napędy obsługujące dokładny strumień i nie buforujące odczytywanych danych. Pozwalają osiągnąć duże szybkości zgrywania, ale nie dają gwarancji, że kopie będą wolne od błędów.

Niewskazane jest w czasie zgrywania bardzo porysowanych lub uszkodzonych płyt, gdy wydaje się, że program wisi nie reagując na polecenia, zabijanie go na siłę w Menadżerze zadań (Alt + Ctrl + Del w Windows XP lub Ctrl + Shift + Esc w Windows 2000/XP), ponieważ napęd może pozostać zablokowany i jedynym sposobem na odblokowanie go będzie ponowne uruchomienie komputera. W takiej sytuacji warto uzbroić się w cierpliwość, gdyż tak naprawdę program pracuje, choć przerwanie zgrywania i zamknięcie go w sposób "pokojowy" wymaga nieraz kilkunastu minut.


Jak zacząć

Wprowadzenie

Exact Audio Copy został wyposażony w kreatora konfiguracji, który jest ukłonem w stronę początkujących użytkowników. Ma za zadanie zautomatyzowanie wstępnej konfiguracji tak, aby można było od razu przystąpić do zgrywania nagrań. Jednak należy mieć na uwadze, że kreator ustawia tylko funkcje istotne, pozostawiając pozostałe w trybie domyślnym. Ustawia również parametry napędów w oparciu o deklaracje zgłaszane przez samo urządzenie, a doświadczenie uczy, że niekiedy deklaracje mają niewiele wspólnego z rzeczywistością.

Niezależnie od tego, czy konfiguracja zostanie przeprowadzona z konfiguratorem, czy bez, pewne opcje trzeba będzie ustawić samemu, a także sprawdzić, czy właściwości napędów są zgodne z deklaracjami. Posługując się tym przewodnikiem proszę, po przeniesieniu się na stronę opisującą działanie ustawianej funkcji, skorzystać z przycisku 'Wstecz' znajdującego się na pasku narzędzi okna pomocy.

Konfiguracja

Jeśli 'Kreator konfiguracji' został użyty, niektóre opcje będą już ustawione. W takim wypadku proszę tylko sprawdzić, czy rzeczywiście są, i przejść dalej. Opcje ustawiane przez 'Kreatora konfiguracji' oznaczone są gwiazdką (*). W nawiasie podano klawisz skrótu, który zaprowadzi bezpośrednio do omawianych ustawień i karta, na której się znajdują.

• Krok pierwszy - komenda odczytu
Konfigurację należy rozpocząć od ustawienia właściwej Komendy odczytu* (F10, karta 'Odczyt').

• Krok drugi - właściwości napędu
Drugim krokiem powinno być ustawienie trybu zgrywania i ewentualne sprawdzenie, czy deklaracje napędu są wiarygodne. Na bezbłędność wyników zasadniczy wpływ mają dwie opcje: 'Napęd buforuje dane audio'* i 'Napęd potrafi zwracać informacje o błędach C2'* (F10, karta 'Tryb zgrywania'). Można włączyć pierwszą z nich i wyłączyć drugą, ale szybkość zgrywania spadnie tak drastycznie, że warto jednak poświęcić chwilę czasu na przeprowadzenie testu.

Do sprawdzania właściwości napędu służy przycisk 'Wykryj właściwości napędu...'. Po włożeniu płyty wystarczy go wcisnąć i poczekać na wyniki.

Nieco trudniej będzie sprawdzić, czy urządzenie ma prawidłowo zaimplementowane zwracanie błędów C2, gdyż do tego potrzebna będzie płyta w złym stanie (porysowana lub wręcz uszkodzona, lecz bez przesady - napęd musi ją przynajmniej w części móc przeczytać). Jeśli takiej płyty nie ma pod ręką, można ją przygotować samodzielnie wypalając i zarysowując. Właściwe ustawienie jest o tyle istotne, że o nieprawidłowym ustawieniu można się przeważnie przekonać dopiero po wypaleniu płyty, na której nagrania trzeszczą lub nawet przeskakują. A ponieważ błędy C2 należą do poważniejszych, trudno znaleźć "normalną" płytę, która by je zawierała (ta uwaga nie dotyczy płyt zabezpieczonych przed kopiowaniem).

Do testowania cechy raportowania przez napęd o wystąpieniu błędu C2 służy przycisk 'Zweryfikuj zwracanie błędów C2...'.

• Krok trzeci - docelowe położenie zgrywanych nagrań
Nie są to ustawienia obowiązkowe, ale wygodne. Można każdorazowo wskazywać miejsce docelowe dla zgrywanych nagrań (włączona opcja 'Każdorazowo pytaj (domyślnie wskazując ostatnio używany folder)'*, F9, karta 'Folder'), lecz bardziej komfortowo będzie z włączoną opcją 'Używaj tego folderu:' i podaną ścieżką (F9, karta 'Folder').

Poza miejscem docelowym dla zgrywanych nagrań ważne są również ich nazwy. Definiuje się je na karcie 'Nazwy plików' (F9). Trzeba pamiętać, że pliki na dysku układane są w kolejności alfabetycznej. Dlatego dobrym rozwiązaniem jest wstawienie na początku nazwy pliku numeru nagrania (zmienna %N). Dzięki temu nagrania zostaną ułożone na dysku w takiej kolejności, w jakiej znajdowały się na płycie.

• Krok czwarty - pozyskiwanie informacji o płycie
Informacje o płycie można uzyskać na dwa sposoby: ręcznie wprowadzając wszystkie dane, co nie jest zbyt wygodne, lecz nie wymaga połączenia internetowego, lub automatycznie z bazy danych freedb. Aby korzystać z drugiego sposobu należy skonfigurować 'opcje freedb' (F12, karta freedb) oraz sposób reagowania programu na płytę nie zawierającą CD-Tekstu, której nie ma w swojej bazie danych. Jeśli program powinien automatycznie łączyć się z freedb i pobierać informacje o każdej włożonej do napędu płycie (której jeszcze nie ma w swojej bazie danych), należy uaktywnić opcję 'Dla nieznanych płyt' i wybrać 'automatycznie połącz się z bazą danych freedb' (F9, karta Ogólne).

Praca z programem

Powyżej opisano wszystkie ustawienia, na które należy zwrócić uwagę przed przystąpieniem do pracy z programem. Po ich skonfigurowaniu można rozpocząć zgrywanie nagrań lub kopiowanie płyt mając pewność, że kopie będą wierne i bezbłędne.


Zgrywanie nagrań z płyt audio

Uwaga

Jeśli niektórych omawianych poniżej pozycji brak w menu oznacza to, że w Kreatorze konfiguracji wybrano wariant 'Jestem zielony, zrób wszystko co się da abym się nie stresował'. Aby przywrócić pełną funkcjonalność programu należy w Opcjach EAC'a, na karcie Narzędzia' wyłączyć opcję 'Włącz tryb dla początkujących, ukryj wszystkie zaawansowane funkcje'.

1. Wprowadzanie informacji o płycie

 Gdy na płycie brak informacji CD-Tekstu, co dotyczy praktycznie wszystkich tłoczonych płyt, a opcja 'Dla nieznanych płyt - automatycznie połącz się z bazą danych freedb, znajdująca się na karcie 'Ogólne' menu 'Opcje EACa' jest włączona, program każdorazowo, po włożeniu nieznanej mu płyty, będzie pobierał o niej informacje łącząc się z freeDB. Można także samodzielnie łączyć się z bazą danych korzystając z ikony [image] lub polecenia menu 'Baza danych'. Program obsługuje tylko freeDB.

Jeśli płyty nie ma w bazie danych niezbędne informacje można wprowadzić samemu. Z menu 'Baza danych' należy wybrać 'Edytuj informacje o płycie...' i wpisać wykonawcę, tytuł płyty oraz - z rozwijanej listy - wybrać rodzaj do jakiego zalicza się zawarta na niej muzyka (jest to wymagane przy wysyłaniu informacji o płycie do FreeDB - menu 'Baza danych' - 'Wyślij informacje o płycie do freedb lub ikona [image]).

Da się to także zrobić w głównym oknie programu. Tutaj zresztą wpisuje się tytuły poszczególnych nagrań. Po wybraniu dowolnego i wciśnięciu klawisza F2 pole przechodzi w tryb edycji. Klawisz Enter zatwierdza wpis i przenosi do następnego pola. Jeśli płyta znajduje się w bazie danych odtwarzacza Windows można ją stamtąd zaimportować. Służy do tego funkcja z menu 'Baza danych' -> 'Pobierz informacje o płycie z - CDPLAYER.INI'. Opisaną płytę można także wyeksportować do bazy danych odtwarzacza Windows ('Eksportuj informacje o płycie do - CDPLAYER.INI', menu 'Baza danych'). Można sobie ułatwić pracę korzystając z możliwości wklejenia tytułów nagrań ze schowka Windows. Aby nie trzeba było poprawiać wprowadzonych informacji wklejane dane powinny zawierać tylko tytuły nagrań w kolejnych wierszach bez żadnych dodatkowych separatorów.

Podsumowując: w 'Opcjach EAC'a', na karcie 'Ogólne' można włączyć opcję automatycznego wyświetlania okna edycji informacji o nieznanej płycie ('Dla nieznanych płyt - otwieraj okno informacyjne'), aby nie trzeba było za każdym razem wywoływać tej funkcji z menu, lub włączyć automatyczne łączenie się z bazą danych freedb ('Dla nieznanych płyt - automatycznie połącz się z bazą danych freedb').

2. Zgrywanie fragmentów płyty lub nagrań

 Funkcja 'Urywki wybranych nagrań' służy do zgrywania zdefiniowanych wcześniej - na karcie 'Urywek' opcji programu - fragmentów nagrań. Z kolei funkcja 'Kopiuj zakres' umożliwia zgrywania całej płyty lub konkretnego fragmentu do jednego pliku. Zgrywając kilka nagrań do jednego pliku suwakiem ustawia się ich ilość, przyciskiem 'Łap utwór' początek lub koniec, a przyciskiem 'Łap przerwę' dodaje lub pomija przerwę (dodawana jest do początku nagrania - górny suwak, odejmowana na końcu - dolny).

3. Zgrywanie nagrań

 Program zgrywa wybrane nagrania lub - gdy żadnego nie zaznaczono - wszystkie. Można najpierw wykryć pozycje przerw (jest to istotne dla duplikowania płyty) w menu 'Akcja', 'Wykryj przerwy', sprawdzić, czy nie zawierają ciszy ('Testuj przerwy na obecność ciszy') i przeprowadzić test zgrywania - 'Testuj wybrane nagrania', a także odsłuchać nagrania.

Aby przystąpić do zgrywania wybranych nagrań z menu 'Akcja' należy wybrać 'Zgrywaj wybrane nagrania' lub ikonę [image]. Otwarte zostanie okno pozwalające śledzić postęp pracy. Można w nim włączyć pole wyboru "Wyłącz komputer po zakończeniu zgrywania", jeśli zanosi się na to, że proces potrwa długo. Jednak komputer zachowa się tak, jak to zostało określone w opcjach - 'Używając funkcji wyłączania - wyłącz/uruchom ponownie' - albo się wyłączy, albo uruchomi ponownie.

4. Korekcja błędów

 Pole "Korekcja błędów" znajdujące się nad okienkiem Stan, po prawej stronie,
składa się z pięciu (trzech lub jednego - zależnie od ustawienia opcji 'Dokładność korygowania błędów') rzędów "diod świecących" po 16 w każdym. Pojedyncza "dioda" to zdublowane ponowienie odczytu (stosowane w EACu techniki zgrywania w trybach pewnych zostały dokładniej omówione przy opisie trybów zgrywania) - jeśli program napotka błąd ponawia odczyt w szesnastu cyklach i jest to obrazowane przez zapalenie się tylu wierszy, ile było cykli. Jeśli wyniki w dalszym ciągu nie są satysfakcjonujące stosowna informacja pojawi się w okienku stanu.

Sygnalizowane błędy odczytu i synchronizacji mogą nie mieć negatywnego wpływu na rezultat końcowy, lecz stanowić jedynie informację. Generalnie bowiem program odczytuje każdy sektor dwa razy porównując wyniki. Gdy napotka błąd, odczytuje podejrzany fragment 16 razy i jeśli 50% lub więcej wyników jest identycznych przechodzi dalej. Jeśli nie - ponawia procedurę do pięciu razy, po czym dodaje informację o niepewnym miejscu do raportu i kontynuuje pracę. Więc zapalenie się wszystkich "diod" oznacza, że błąd był poważny i program sobie z nim nie poradził.

5. Raport

 Raport wyświetlony po zakończeniu zgrywania zawiera uwagi dotyczące każdego nagrania. "Poziom wysterowania" to informacja o poziomie najgłośniejszych fragmentów w odniesieniu do maksymalnego możliwego (100%). Z kolei "Jakość nagrania" mniejsza od 100% oznacza, że musiało nastąpic ponowienie odczytu. W raporcie wyszczególniane są także wszystkie poważne błędy. Przycisk 'Możliwe błędy' kryje listę wszystkich niepewnych miejsc, które można od razu odsłuchać i podjąć decyzję o dalszym postępowaniu. Za pomocą edytora, który wywołuje się z menu 'Narzędzia' - 'Edytuj plik WAV...', można spróbować skorygować błędne fragmenty.

Po zakończeniu zgrywania główne okno zawiera wszystkie dane. Jeśli wcześniej przeprowadzony został test ('Testuj i zgrywaj wybrane nagrania, menu 'Akcja') można porównać sumy kontrolne.

Plik raportu, zawierający informacje o przebiegu procesu zgrywania, noszący nazwę wygenerowaną z tytułu płyty i rozszerzenie log, będzie tworzony automatycznie, jeśli w menu EAC na karcie Narzędzia zostanie włączona opcja Automatycznie zapisuj sprawozdanie po zgraniu nagrań. Jednak niezależnie od ustawienia tej opcji raport zostanie zapisany w folderze wybranym w menu EAC na karcie Folder, jeżeli wybrana została funkcja Wyłącz komputer po zakończeniu zgrywania. Jest to szczególnie przydatne w sytuacji, gdy zgrywana jest bardzo zniszczona płyta. Po automatycznym wyłączeniu komputera w pliku raportu znajdą się informacje pozwalające zorientować się, czy podczas zgrywania nie wystąpiły błędy odczytu lub synchronizacji.

6. Kompresja

 Exact Audio Copy pozwala na kompresowanie nagrań. Można zażyczyć sobie, aby po skompresowaniu wyjściowe pliki wav pozostały na dysku wyłączając opcję 'Skasuj plik wav po zakończeniu kompresji'). Da się także skonfigurować kilka różnych koderów. Aby to zrobić należy każdorazowo zapisać konfigurację w profilu. Można wybierać spośród koderów zainstalowanych w systemie (karta 'Format audio' menu 'EAC', 'Opcje kompresji') lub skonfigurować zewnętrzny programu wywoływany z linii poleceń (karta 'Zewnętrzna kompresja' menu 'EAC', 'Opcje kompresji'). Z uwagi na to, że istnieje bardzo dużo koderów, program należy konfigurować dla każdego z nich indywidualnie, ponieważ ustawienia nie są ujednolicone.

• Przykład
Aby skonfigurować bezstratny koder WavPack należy z listy 'Schemat podstawianych parametrów' wybrać 'Koder użytkownika', w polu 'Używaj rozszerzenia pliku' wpisać .wv, podać ścieżkę do pliku wykonywalnego w polu 'Program, łącznie ze ścieżką, użyty do kompresji' i wreszcie w polu 'Dodatkowe opcje linii poleceń' wpisać -h %s %d (bez znaczników) lub -w "Artist=%a" -w "Title=%t" -w "Album=%g" -w "Year=%y" -w "Track=%n" -w "Genre=%m" -h %s %d (ze znacznikami). Dodatkowo trzeba wyłączyć opcje 'Używaj sprawdzania sumy kontrolnej CRC', 'Dodawaj znacznik ID3' oraz 'Sprawdzaj kod zwrotny zewnętrznego programu'. Rozwijana lista 'Przepływność bitów' jest ignorowana.

Jeśli w systemie zainstalowany jest kodek Monkey's Audio, ustawienie bezstratnej kompresji jest jeszcze prostsze. Wystarczy w menu Opcje kompresji, na karcie Format audio z rozwijanej listy Format audio wybrać Monkey's Audio Lossless Encoder i określić preferowany Format próbki.

7. Porównywanie plików wav

 EAC umożliwia porównywanie plików muzycznych (menu Narzędzia, funkcja Porównaj pliki wav...). Jeśli jednak wyniki mają być miarodajne, to oba porównywane nagrania powinny być zgrywane w ten sam sposób i - w miarę możliwości - na tym samym modelu napędu, z uwagi na wprowadzane przesunięcie. Należy mieć także na uwadze fakt, że przerwa dodawana jest do końca nagrania. Porównywanie plików może być mniej lub bardziej dokładne (dokładność ustawia się w menu Opcje edytora WAV na karcie Porównywanie). Zwiększenie dokładności odbywa się jednak kosztem szybkości. Dla plików mających bardzo wiele różnic (a szczególnie kompletnie różnych) cała operacja może trwać bardzo długo.


Kopiowanie płyt audio

W Exact Audio Copy możliwe jest kopiowanie płyt w oparciu o arkusz dyrektyw. Służy do tego funkcja z menu 'Akcja' -> 'Utwórz obraz i arkusz dyrektyw'. "Obrazem" będzie plik wav zawierający całą płytę. Arkusz dyrektyw (plik *.cue) natomiast zawiera wszystkie informacje niezbędne do wypalenia jej jako wiernej kopii. Nagrania znajdujące się już na dysku można "powiązać" z oryginalną płytą za pomocą funkcji, znajdującej się w tym samym menu 'Utwórz arkusz dyrektyw'. Program utworzy jedynie plik *.cue, nie zgrywając powtórnie nagrań i umieści go w miejscu zdefiniowanym na karcie 'Folder' menu 'Opcje EAC'a'. Z kolei istniejący na dysku plik wav można "podzielić" przeznaczonym dla niego arkuszem dyrektyw. Odpowiednia funkcja znajduje się w menu 'Narzędzia' ('Podziel plik wav arkuszem dytrektyw').

Kopia nie będzie wierna, jeśli nie będzie zawierała takich samych jak w oryginale przerw pomiędzy nagraniami. Tworzenie obrazu poprzedzone jest więc wykrywaniem przerw. Dlatego bardzo ważne jest ustawienie właściwego sposobu w 'Opcjach napędu' na karcie 'Wykrywanie przerw', ponieważ w przeciwnym wypadku cała operacja może trwać bardzo długo. Program umożliwia także wstawianie standardowych dwusekundowych przerw, lub usuwanie ich.


Wypalanie

1. Przygotowanie materiału

 Exact Audio Copy umożliwia wypalanie płyt. Nie jest to jednak takie proste jak w programach specjalnie do tego celu przeznaczonych. W końcu służy głównie do zgrywania nagrań. Wypalać można jedynie za pomocą utworzonego automatycznie lub samodzielnie arkusza dyrektyw. Odpowiednia funkcja znajduje się w menu 'Narzędzia' pod nazwą 'Wypalanie - Edytor układu płyty'. Wybranie jej nie spowoduje rozpoczęcia wypalania lecz jedynie otwarcie edytora, do którego należy wczytać plik obrazu.

2. Tworzenie arkusza dyrektyw

 Można samodzielnie stworzyć arkusz dyrektyw od podstaw dla nagrań, które znajdują się już na dysku albo dodając je kolejno, albo ręcznie tworząc cały obraz płyty. Służy do tego edytor, który umożliwia zmianę tytułów poszczególnych nagrań, usuwanie ich oraz dodawanie nowych. Dzięki niemu można się także pokusić o wstawienie między nagrania przerw zawierających na przykład oklaski. Jak to zrobić gdy płyta została zgrana w całości jako jeden wielki plik wav? Wczytać ten plik otwierając menu 'Układ' i wybierając 'Dołącz pliki jako nowe nagranie (Indeks 0 i 1)'. Stan wyjściowy widać na rysunku poniżej:

Z menu 'Plik' należy wybrać 'Edytuj arkusz dyrektyw'. Widać ścieżkę do pliku, numer nagrania i dwa indeksy. Pierwszy to przerwa, która zawsze znajduje się przed pierwszym nagraniem i drugi - właściwe nagranie.

Uwaga: Przed pierwszym nagraniem na płycie MUSI zawsze znajdować się dwusekundowa przerwa (czy wstęp, jak kto woli), w przeciwnym wypadku wypalanie może się nie powieść. Niektóre nagrywarki dopuszczają większą jej długość, lecz żadna nie akceptuje mniejszej!

Teraz nagranie musi zostać podzielone. Jeśli płyta ma zawierać CD-Tekst najpierw podaje się nazwę wykonawcy:
PERFORMER "NazwaWykonawcy"
Następnie tytuł płyty:
TITLE "TytułPłyty"
dopiero trzecia będzie ścieżka do pliku wav i jego rodzaj
FILE "Ścieżka\do\pliku" WAVE
Po niej określa się numer i rodzaj nagrania:
TRACK 01 AUDIO
Dalsze dwie linie to powtórzenie w odwrotnej kolejności wykonawcy i tytułu, ale dotyczące już nie płyty, lecz nagrania:
TITLE "TytułNagrania1"
PERFORMER "WykonacaNagrania1"
To jest miejsce, gdzie zaczyna się pierwsze nagranie:
INDEX 01 00:00:00
Teraz nadeszła pora na drugie nagranie:
TRACK 02 AUDIO
Znowu, jak poprzednio trzeba podać tytuł i wykonawcę nagrania - tym razem drugiego -
TITLE "TytułNagrania2"
PERFORMER "WykonacaNagrania2"
i ustawić koniec pierwszego nagrania, a zarazem początek przerwy, na przykład:
INDEX 00 04:58:30
Koniec przerwy wypadł przykładowo tu:
INDEX 01 05:04:20<br> Zaczyna się trzecie nagranie:
TRACK03 AUDIO
TITLE "TytułNagrania3"
PERFORMER "WykonacaNagrania3"
Czasy w tym wypadku są czasami absolutnymi - czyli liczonymi od początku płyty Pliku). Aby więc we właściwe miejsca wstawić zakończenia nagrań trzeba zsumować czasy ich trwania. Czyli koniec nagrania drugiego to będzie już na przykład
INDEX 00 09:11:40
a początek trzeciego
INDEX 01 09:26:20
Podział pliku może więc wyglądać tak, jak na rysunku:

Żeby się nie pogubić należy pamiętać, że przerwa wstawiana jest PRZED nagraniem i jest traktowana jako jego część składowa. Natomiast przy zgrywaniu dołączana jest do KOŃCA nagrania. Przerwy (czy wstępu, jak kto woli) przed pierwszym nagraniem na płycie nie czyta ŻADEN odtwarzacz (oczywiście dopóki mu się nie włączy przewijania wstecz). Pomocą będzie to, że w każdej chwili można obejrzeć efekty pracy w głównym oknie edytora, odsłuchać i skorygować wprowadzone wartości. Można także przesłuchać cały plik i wynotować czasy zakończenia i rozpoczęcia nagrań. Końcowy efekt wygląda następująco:

Powyższy opis dotyczył całej płyty nagranej jako pojedynczy plik wav. Gdy płytę zgrano do osobnych plików sposób postępowania jest analogiczny, ale tu sprawa się komplikuje o tyle, że dodatkowo trzeba uważać, którego pliku modyfikacje dotyczą, aby nie porobić przerw w niezamierzonych miejscach i zbyt długich. Natomiast upraszcza się sprawa określania czasu rozpoczęcia nagrania - każde startuje od pozycji 00:00:00 (chyba, że z jakichś powodów przerwa ma zawierać fragment nagrania). Poniższy przykład powinien rozwiać wszelkie wątpliwości:

PERFORMER "Grand Funk Railroad" | Nazwa wykonawcy
TITLE "Caught In The Act" | Tytuł płyty
FILE "E:\Caught In The Act\01 Foot Stompin Music.wav" WAVE |  | Lokalizacja pliku pierwszego nagrania
TRACK 01 AUDIO | Pierwsze nagranie
TITLE "Foot Stompin' Music" | Tytuł pierwszego nagrania
PERFORMER "Grand Funk Railroad" | Wykonawca pierwszego nagrania
INDEX 01 00:00:00 | Początek pierwszego nagrania
TRACK 02 AUDIO | Drugie nagranie
TITLE "Rock & Roll Soul" | Tytuł drugiego nagrania
PERFORMER "Grand Funk Railroad" | Wykonawca drugiego nagrania
INDEX 00 04:08:00 | Początek przerwy po PIERWSZYM nagraniu - w obrębie pierwszego pliku!
FILE "E:\Caught In The Act\02 Rock & Roll Soul.wav" WAVE | Lokalizacja pliku drugiego nagrania
INDEX 00 00:00:00 | Przerwa ma obejmować także początek drugiego nagrania, więc drugi plik rozpoczyna się indeksem 0
INDEX 01 00:01:50 | Początek drugiego nagrania w obrębie drugiego pliku
TRACK 03 AUDIO | Trzecie nagranie
TITLE "Closer To Home" | Tytuł trzeciego nagrania
PERFORMER "Grand Funk Railroad" | Wykonawca trzeciego nagrania
INDEX 0003:51:50 | Początek przerwy po DRUGIM nagraniu w obrębie drugiego pliku
FILE "E:\Caught In The Act\03 Closer To Home.wav" WAVE | Lokalizacja pliku trzeciego nagrania
itd. | i tak dalej

3. Wypalanie

 Po zakończeniu modyfikacji można odsłuchać cały projekt dokładnie tak, jak zostanie wypalony i ewentualnie poprawić czasy rozpoczęcia i zakończenia poszczególnych nagrań - rzut oka na pozycję "Czas" pozwoli zorientować się gdzie i ewentualnie o ile skorygować wprowadzone wartości. Można także poszczególne części wielowątkowego nagrania rozdzielić indeksami. Wystarczy po prostu wpisać INDEX z kolejnym dwucyfrowym numerem (pamiętając, że INDEX 00 to przerwa) i określić miejsce, gdzie ma się on znaleźć (oczywiście w obrębie nagrania). Maksymalnie można wstawić 99 indeksów.

Gdy już wszystko jest przygotowane i zgodne z oczekiwaniami czas przystąpić do wypalania - w menu 'Płyta' należy wybrać 'Wypalaj...' i czekać na rezultat. Sam proces wypalania można przeprowadzić na dwa sposoby. Albo powierzyć go wewnętrznym procedurom wbudowanym w EAC'a (bardziej stabilnym), albo skorzystać z zewnętrznego programu linii poleceń CDRDAO, który z kolei obsługuje większą liczbę nagrywarek. Decyzję, który program wybrać należy podjąć przed rozpoczęciem wypalania włączając lub wyłączając opcję znajdującą się w menu 'EAC', 'Opcje EACa' na karcie 'Wypalanie'.

Menu 'Płyta' zawiera także inne przydatne funkcje związane z wypalaniem, jak test pojemności nośnika ('Testuj pojemność nośnika...') i kasowanie płyty CD-RW ('Szybkie kasowanie CD-RW').

4. Wykrywanie zawartości płyty

 Funkcja ręcznego wykrywania zawartości płyty ('Zmiany w TOC' -> 'Odzyskaj prawidłowy TOC') może być użyta dla uszkodzonych płyt i gdy nagrania mają nieprawidłowe czasy trwania lub gdy zgłaszają się jako dane. Przydaje się także do omijania zabezpieczeń. Czasami napęd bez użycia tej opcji nie zobaczy płyty. Jedynym wymogiem w tej sytuacji jest, aby potrafił wykrywać przerwy w trybie B (co sprawdza się i ustawia w 'Opcjach napędu' na karcie 'Wykrywanie przerw').


Edytor wav

Omówienie

Do Exact Audio Copy został dołączony mały edytor dźwięku. Obsługuje standardowe (16 bitów, 44 100 Hz), nieskompresowane pliki wav. Wywołuje się go z menu 'Narzędzia' -> 'Edytuj plik wav...'. Można wczytać jednorazowo tylko jeden plik.

Podstawowe funkcje zostały podzielone na wykonywane na całym pliku ('Przetwarzanie ogólne') i dotyczące tylko zaznaczonego fragmentu ('Przetwarzanie zaznaczenia').

I. Przetwarzanie ogólne

1. Normalizacja

 Normalizacja teoretycznie służy do wyrównywania poziomu głośności poszczególnych nagrań. Teoretycznie, ponieważ jej działanie polega na korygowaniu tylko poziomu wysterowania - amplitudy sygnału, która ma wprawdzie bezpośredni, lecz nie decydujący wpływ na głośność dźwięku. Głośność bowiem zależy głównie od częstotliwości i widma sygnału. To oznacza, że nagranie mające większą (lub skompresowaną) dynamikę może być dużo głośniejsze mimo, że ma stosunkowo małą amplitudę.

Przed zastosowaniem tej funkcji trzeba więc wziąć pod uwagę, że wyrównuje ona tylko poziom wysterowania sygnału, za punkt odniesienia przyjmując miejsce, w którym amplituda osiągnęła największą wartość. Pojedynczy impuls szpilkowy lub trzask mogą całkowicie zniweczyć efekt końcowy. Całe nagranie zostaje wzmocnione proporcjonalnie, a punktem odniesienia jest zakłócenie. Jeśli się pamięta, że 100% to maksymalny możliwy poziom nie powodujący wystąpienia cyfrowego przesterowania, nie powinno dziwić, że gdy choć jedna próbka osiągnęła wartość 0 dB - nic się nie zmieni. A wręcz przeciwnie - jeżeli maksymalna wartość ustawiona została na mniej niż 100% - poziom wysterowania może się zmniejszyć.

Normalizacja jest przydatna w zasadzie tylko dla nagrań pochodzących z różnych płyt, z których każda jest nagrana z innym poziomem wysterowania. Natomiast jej stosowanie staje się problematyczne, a wręcz niepożądane, gdy utwory na płycie są poddane kompresji dynamiki. Istotą jej działania jest bowiem spłaszczenie przebiegu sygnału z jednoczesnym podniesieniem poziomu wysterowania do 0 dB. Niejednokrotnie powoduje to wystąpienie przesterowań. W uproszczeniu ilustruje to poniższy rysunek.

Przed zastosowaniem tej funkcji warto również rozważyć trzy aspekty. Po pierwsze - różnice w głośności poszczególnych nagrań mogą być zamierzone i jak najbardziej na miejscu, ponieważ taki był zamysł twórcy. Po drugie - przy nagraniach przechodzących jedno w drugie (na przykład suita, opera, symfonia czy koncert) skoki głośności mogą być słyszalne. I wreszcie po trzecie - jeśli nie zostanie wpierw skorygowana składowa stała, to nagranie będzie w dalszym ciągu cichsze od takiego, które składowej stałej nie ma.

2. Usuwanie składowej stałej

 Nagrania często mają tak zwaną składową stałą (zwłaszcza nagrywane za pośrednictwem karty dźwiękowej z płyt winylowych lub taśm). Jej obecność powoduje przesunięcie przebiegu względem zera. Widać to na rysunku poniżej.

Sinusoida nie jest symetryczna względem zera, lecz przesunięta do góry (oczywiście jest to bardzo przesadzona sytuacja, ale pozwala zorientować się o co chodzi). Korekcja składowej stałej przywraca prawidłową symetrię sygnału względem zera.

II. Przetwarzanie zaznaczenia

1. Usuwanie impulsów szpilkowych

 Za pomocą tej funkcji można usuwać impulsy szpilkowe z sygnału.

Program usuwa je liniowo interpolując punkty znajdujące się bezpośrednio w ich sąsiedztwie. Usuwane są tylko tego typu zniekształcenia sygnału. Powyższe rysunki ilustrują działanie funkcji.

2. Interpolacja

 Jeśli zaznaczony fragment jest dostatecznie mały (w przeciwnym razie funkcja jest niedostępna) można interpolować uszkodzone miejsce zastępując je przebiegiem znajdującym się od niego na prawo i na lewo. Natomiast liniowa interpolacja połączy oba końce zaznaczenia linią prostą. Dlatego taka modyfikacja ma sens przy korygowaniu poszczególnych próbek, których amplituda odbiega od normy. Po dużym powiększeniu możliwa staje się także ręczna modyfikacja przebiegu sygnału.

3. Automatyczne wykrywanie trzasków

 Za pomocą tej funkcji można spróbować wykryć trzaski w zaznaczonym obszarze. Zależnie od ustawień - im większa - czyli bliższa 0 dB, czułość, tym dłużej będzie trwał cały proces i więcej trzasków zostanie wykrytych. Istnieje jednak niebezpieczeństwo, że mogą zostać znalezione nawet tam, gdzie wcale nie występują.

Po zakończeniu skanowania zostanie wyświetlone okno ze wszystkimi znalezionymi trzaskami. Podwójne kliknięcie na wpisie zaznaczy odpowiadający mu fragment nagrania. Można go spróbować skorygować za pomocą funkcji 'Wygładź zaznaczony przebieg', stosując ją - w razie potrzeby - wielokrotnie dla tego samego zakresu.

4. Wygładzanie przebiegu

 Ta funkcja pozwala wygładzać przebieg zawierający trzaski i zakłócenia. Wygładzanie polega na filtrowaniu wysokich częstotliwości - jest to rodzaj filtru dolnoprzepustowego. Częstotliwości leżące powyżej określonej wartości są tłumione - następuje redukcja ich amplitudy. Wygładzanie można stosować wielokrotnie dla tego samego fragmentu.

5. Redukcja szumu

 Przed przystąpieniem do usuwania szumu z nagrania należy utworzyć profil. Można go wczytać z dysku lub zaznaczyć mały fragment (około pół sekundy) i korzystając z funkcji 'Pobierz z zaznaczenia' od razu wykorzystać lub zapisać i stosować do innych plików pochodzących z tego samego źródła. Fragment stanowiący wzorzec nie powinien zawierać niczego poza czystym szumem, w przeciwnym wypadku sygnał może zostać zniekształcony. Im wyższy poziom tłumienia, tym redukcja będzie bardziej radykalna, ale jednocześnie może powodować pojawienie się słyszalnych zniekształceń.


Kreator konfiguracji

Exact Audio Copy został wyposażony w bardzo przydatną dla mniej zaawansowanych użytkowników funkcję - kreatora konfiguracji. Jej zadaniem jest ułatwienie i przyspieszenie rozpoczęcia pracy z programem. Oczywiście skorzystanie z niego nie wyklucza możliwości późniejszego samodzielnego skonfigurowania poszczególnych opcji.

Praca z kreatorem polega na udzieleniu odpowiedzi na kilka prostych pytań. Jednak niektóre opcje należy ustawić samodzielnie (jak choćby główny folder dla zgrywanych plików muzycznych, czy generowanie nazw plików).

Należy zwrócić uwagę na zainstalowane w systemie wirtualne napędy (np. z CloneCD) i nie wybierać ich w oknie wyboru napędu kreatora. Dopiero po zdecydowaniu, czy EAC ma pokazywać wszystkie (ekspert), czy ukryć niektóre zaawansowane (początkujący) opcje ustawienia zostaną zapisane. Z konfigurowania za pomocą kreatora można zrezygnować w dowolnym momencie bez obawy, że jakiekolwiek ustawienia zostaną zmienione.

Wykrywanie cech napędów dotyczące zwracania błędów C2 opiera się na informacjach zgłaszanych przez urządzenia. Nie zawsze jest to do końca zgodne z rzeczywistością. Dlatego zaleca się po zakończeniu pracy kreatora zbadać stan faktyczny za pomocą funkcji 'Zweryfikuj zwracanie błędów C2...'


Konfiguracja programu

Konfiguracja programu może sprawić pewne kłopoty początkującym, ale przebrnięcie przez nią da wiele satysfakcji i pewność, że kopie nagrań są perfekcyjne i nie zawierają żadnych niepożądanych artefaktów. Można w ostateczności skorzystać z 'Kreatora konfiguracji', a po oswojeniu się z programem spróbować samodzielnie dopasować niektóre ustawienia do własnych potrzeb.


Opcje EAC'a

Po uruchomieniu Exact Audio Copy i wybraniu z menu 'EAC', 'Opcje EAC'a' (lub wciśnięciu klawisza F9) ukazuje się okno ustawień programu z szeregiem kart.

Wszystkie dokonane zmiany należy zatwierdzić przyciskiem 'OK'. Dobrze jest także zamknąć i ponownie uruchomić program.

Po zakończeniu konfiguracji można ją zapisać w profilu. Jest to funkcja dostępna na pasku stanu lub w menu 'EAC'.

Można utworzyć i zapisać kilka alternatywnych konfiguracji. Na przykład po skonfigurowaniu kilku różnych kodeków do kompresowania nagrań. Aby następnie skorzystać z któregoś z nich wystarczy wczytać odpowiedni profil.


Opcje EAC'a - Zgrywanie

Ustawienia

Uzupełniaj brakujące próbki ciszą
Gdy używana jest korekta przesunięcia, a napęd nie potrafi nadczytywać z obszarów LeadIn i LeadOut, włączenie tej opcji spowoduje, że brakujące próbki zostaną uzupełniane. Dzięki temu długość zgranego nagrania będzie taka sama, jak oryginalnego. Ta funkcja jest też istotna z uwagi na AccurateRip. Zobacz dział w całości jej poświęcony: Funkcja AccurateRip, a także: 'Przesunięcie/szybkość'.

Nie używaj zerowych próbek do przeliczania sumy kontrolnej
Przy wyliczaniu sum kontrolnych są także brane pod uwagę zerowe próbki. Ta opcja nie ma żadnego praktycznego znaczenia dla procesu zgrywania nagrań, może być jedynie przydatna przy eksperymentach z korektą przesunięcia, gdyż sumy kontrolne nie będą od niego zależne.

Synchronizuj styk nagrań
Program potrafi korygować błędy synchronizacji (jitter) na styku nagrań w celu wyeliminowania możliwych przerw lub trzasków. Działa to jedynie wtedy, gdy zgrywane są sąsiadujące, połączone ze sobą nagrania. Można tę opcję włączyć na stałe.

Usuwaj początkowe i końcowe bloki ciszy
Jeśli w nagraniu na początku lub/i końcu znajdują się bloki zawierające tylko ciszę - zostaną usunięte. Ta funkcja jest przydatna w przypadku, gdy nagrania zostały sztucznie wydłużone przez dodanie do nich ciszy. Zdarzają się bowiem płyty (zwłaszcza starsze), na których "zwykłe" przerwy są dodatkowo "uzupełnione" ciszą zawartą w samych nagraniach. Nie należy tej opcji włączać, jeśli ma działać AccurateRip. Więcej szczegółów na ten temat znajduje się w dziale Funkcja AccurateRip

Pomiń zgrywane nagranie przy błędach odczytu lub synchronizacji
Program po napotkaniu błędu przerwie zgrywanie uszkodzonego nagrania i rozpocznie zgrywanie następnego. Jednak dzięki zastosowaniu zaawansowanego algorytmu odczytu danych audio bardzo często błędy odczytu/synchronizacji są kompletnie niesłyszalne. Natomiast gdy wystąpi błąd będzie on uwzględniony w sprawozdaniu, więc można wtedy przesłuchać niepewny fragment i samemu zadecydować, co robić dalej. Bardzo rzadko zdarza się wadliwie wytłoczona płyta, częściej zaś porysowana lub zabrudzona. W takim przypadku mogą zostać pominięte wszystkie nagrania.

Pomiń nagranie, jeśli zgrywanie trwa to dłużej niż x jego długości
Jeśli minie zdefiniowany tutaj czas zgrywania - a oznacza to, że korekcja błędów ma wiele pracy - nagranie zostanie pominięte.

Po każdych xx minutach zgrywania pozwól stygnąć czytnikowi przez yy min.
Po bardzo trudnym i długotrwałym odczycie płyty lub nagrania rojącego się od błędów, można ptrzerwać zgrywanie na określony czas aby napęd mógł ostygnąć. Intensywnie eksploatowane przez długi czas urządzenie nagrzewa się i spada jego wydajność. Zbyt intensywnie eksploatowane może nawet ulec uszkodzeniu, a na pewno skraca się jego żywotność.

Zablokuj szufladkę napędu na czas zgrywania
Przypadkowe otwarcie szufladki w trakcie zgrywania spowoduje, że EAC znajdzie się w "nieznanym stanie". Nie wszystkie systemy operacyjne są sobie w stanie z tym poradzić i jedynym sposobem na odblokowanie komputera może być jego ponowne uruchomienie.

Priorytet zgrywania i kompresji
W zasadzie pozycja "Normalny" jest optymalna i nie ma potrzeby jej zmieniać. Zwiększenie priorytetu może spowodować, że inne programy zaczną pracować "skokami".

Uwaga: Przy zgrywaniu bardzo porysowanych lub uszkodzonych płyt praca EACa może tak dalece spowolnić działanie komputera, że wygląda jakby się zawiesił. Przed podjęciem drastycznych kroków należy odczekać nawet kilka minut. Klikanie przycisku 'Anuluj' może nie przynieść żadnych efektów dopóki program nie zakończy cyklu korekcji błędów. Jeśli takie symptomy występują zbyt często można zmniejszyć priorytet zgrywania.

Dokładność korygowania błędów
To ustawienie określa ile razy ponowiony zostanie odczyt w wypadku napotkania błędu. Ma znaczenie jedynie wtedy, gdy zgrywana płyta jest w nie najlepszym stanie. Są do wyboru trzy poziomy dokładności. Oczywiście im wyższy, tym wolniejsza praca w obszarze zawierającym błędy, ale też większe prawdopodobieństwo, że zostaną poprawnie skorygowane.


Opcje EAC'a - Ogólne

Ustawienia

Używaj alternatywnego sposobu odtwarzania płyt
Czytnik lub nagrywarka odtwarzają po połączeniu ich wyjścia analogowego z kartą dźwiękową. To ustawienie umożliwia cyfrowy przesył sygnału, więc żadne dodatkowe połączenie nie jest konieczne. W Windows 2000 i XP taki sposób odtwarzania można ustawić dla wszystkich programów w "Menadżerze urządzeń".

Zablokuj 'Autopowiadamianie' dla audio i danych w czasie działania EAC'a
Po włożeniu płyty rozpoczyna się automatyczne odtwarzanie lub uruchamianie zawartego na niej oprogramowania (oczywiście jeśli ta funkcja nie jest całkowicie zablokowana w ustawieniach Windows). Włączenie tej opcji blokuje autopowiadamianie na czas działania programu.

Dla nieznanych płyt
automatycznie połącz się z bazą danych freedb lub
otwórz okno informacyjne
Jeśli do napędu włożona zostanie płyta, o której brak informacji, program może automatycznie połączyć się z bazą danych freedb i pobrać potrzebne dane (oczywiście wcześniej trzeba poprawnie skonfigurować opcje internetpowe dla freedb). Istnieje także możliwość samodzielnego zainicjowania połączenia (menu 'Baza danych' -> 'Pobierz informacje o płycie z' -> 'Internetowa freedb' lub ikona [image]). Przy stałym połączeniu z Internetem wygodnie jest jednak włączyć tę opcję. Jeśli w bazie danych nie ma informacji o płycie można samodzielnie je wprowadzić, a następnie wysłać (menu 'Baza danych' -> 'Wyślij informacje o płycie do freedb' lub ikona [image]).

Wyświetlaj czas używając ramek
Możliwe jest wyświetlanie informacji o czasie w głównym oknie programu na dwa sposoby: w setnych sekundy (1/100s) i w ramkach (1/75s). Ten drugi sposób jest bardziej naturalny dla płyt. 1 sekunda to 75 ramek.

Pytaj zanim nadpiszesz pliki
Jeżeli nagranie o takiej samej nazwie już istnieje na dysku, program zapyta, czy ma go zastąpić właśnie zgrywanym.

Koryguj błąd złej kolejności plików przy wyborze wielu plików w Windows
Zaznaczenie wielu plików w celu ich otwarcia w Windows (od 95 poczynając a na XP kończąc) skutkuje tym, że zamieniane są miejscami pliki pierwszy i ostatni. Dlatego należy rozpoczynać wybór od ostatniego pliku lub włączyć tę opcję.

Pokazuj okno dialogowe sprawozdania po zgraniu nagrań
W tym oknie wyświetlane są wszystkie informacje na temat przebiegu zgrywania i ewentualnych błędów.

Sygnalizuj dźwiękiem zakończenie zgrywania
Zakończenie zgrywania nagrań może być sygnalizowane dźwiękiem (generowanym przez głośniczek komputera, a nie kartę dźwiękową).

Wysuń szufladkę po zakończeniu zgrywania
Po zakończeniu zgrywania płyta zostanie wysunięta automatycznie.

Używając funkcji wyłączania
czekaj na zewnętrzne kompresory
wyłącz komputer
uruchom ponownie komputer
Tutaj można zdecydować jaką akcję ma podjąć program po zakończeniu zgrywania.

Wybór języka
Tutaj można wybrać jeden z dostępnych języków w jakim będzie pracował program.


Opcje EAC'a - Narzędzia

Ustawienia

Odtwórz kody UPC/ISRC przy generowaniu arkusza dyrektyw
Przy tworzeniu arkusza dyrektyw dla płyty możliwe jest odtworzenie kodów UPC i ISRC. W praktyce amatorskiej te kody nie mają żadnego znaczenia.

Używaj informacji CD-Tekstu przy tworzeniu arkusza dyrektyw
Dodane zostaną informacje o płycie (wykonawca, tytuł, tytuły nagrań) do arkusza dyrektyw. Jeśli nagrywarka potrafi wypalać CD-Tekst, płyta po wypaleniu będzie zawierała wszystkie te informacje.

Utwórz listę odtwarzania '.m3u'
Po włączeniu tej funkcji program będzie automatycznie tworzył listę odtwarzania (którą można wykorzystać na przykład w programie WinAmp), pod nazwą generowaną z nazwy płyty i w folderze, do którego są zgrywane nagrania. Może to być użyteczne przy tworzeniu skompresowanych plików muzycznych.

Dopisuj do listy .m3u rozszerzone informacje
Lista odtwarzania .m3u oprócz zgodnego z zamierzeniami ułożenia nagrań w odpowiedniej kolejności może dodatkowo zawierać także informacje na temat długości nagrań, ich tytułów itp. W tej chwili nieliczne nowe programy służące do odtwarzania plików muzycznych potrafią skorzystać z tych informacji. Starsze mogą pracować nieprawidłowo, ponieważ nie tolerują żadnych komentarzy w plikach .m3u, a te dodatkowe wpisy tworzonę są właśnie jako komentarze.

Automatycznie zapisuj sprawozdanie po zgraniu nagrań
Po zgraniu nagrań automatycznie zostanie utworzony plik, o nazwie wygenerowanej z tytułu płyty, zawierający informacje o przebiegu procesu. Jeśli wybrana została opcja Wyłącz komputer po zakończeniu zgrywania, znajdująca się w oknie Zgrywanie nagrań audio, raport zostanie zapisany niezależnie od ustawienia tej opcji w folderze wybranym w menu EAC na karcie Folder. Czy komputer ma zostać wyłączony, czy uruchomiony ponownie, ustawia się w menu EAC na karcie Ogólne, funkcja Używając funkcji wyłączenia - wyłącz/uruchom.

W tle procesu zgrywania rozpocznij kolejkę zewnętrznych kompresorów
Ta opcja pozwala w trakcie zgrywania kompresować nagrania. Aby móc kompresować płytę lub poszczególne nagrania z niej należy skonfigurować poprawnie i zgodnie z potrzebami opcje kompresji znajdujące się w menu 'EAC' 'Opcje kompresji'.

Użyj x jednoczesnego(ych) wątku(ów) zewnętrznej kompresji
Można ustawić ilość jednoczesnych wątków. Należy jednak zwrócić uwagę na fakt, że zgrywanie i kompresja będą przebiegać jednocześnie, co może stwarzać pewne problemy na wolnych komputerach. W skrajnych przypadkach oba procesy mogą wzajemnie sobie przeszkadzać generując błędy.

Nie otwieraj okna zewnętrznego kompresora
Program wywołuje okno kompresora pozwalając zorientować się w postępach operacji.

Prześlij wykryte cechy napędu (ale zapytaj o zgodę)
Po każdorazowym użyciu funkcji "Wykryj cechy odczytu..." i "Zweryfikuj działanie C2..." program poprosi o wysłanie wyników do bazy danych cech napędów. Dzięki temu inni użytkownicy będą mogli znaleźć w niej potrzebne informacje w razie kłopotów z konfiguracją.

Włącz tryb dla początkujących, ukryj wszystkie zaawansowane funkcje
Uaktywnienie tej opcji spowoduje ukrycie kilku dodatkowych funkcji programu zwykle dostępnych w menu "Akcja".


Opcje EAC'a - Normalizacja

Omówienie

Na czym polega normalizacja i jakie pułapki skrywa zostało dokładnie omówione przy okazji opisu działania Edytora wav. Zapoznanie się z tematem pomoże w podjęciu decyzji, czy warto włączać tę funkcję.

Ustawienia

Normalizuj
Włącza funkcję wyrównywania poziomu wysterowania zgrywanych nagrań.

Normalizuj do
Tu określa się do jakiej wartości wyrównywany ma być poziom wysterowania. 100% to maksymalna możliwa wartość, która nie powoduje cyfrowego przesterowania.

Ale tylko wtedy, gdy wartości szczytowe są mniejsze niż x% lub większe niż y%
Tutaj ustala się warunki, jakie ma spełniać poziom wysterowania nagrania, aby nastąpiła korekta. Program będzie ingerował tylko wtedy, gdy amplituda nagrania będzie mniejsza lub większa od wprowadzonych tu wartości.


Opcje EAC'a - Nazwy plików

Ustawienia

Składnia nazw plików
Pliki, które powstaną po zgraniu płyty, będą miały nazwy i będą się znajdować w podfolderach zdefiniowanych tutaj. Folder główny definiuje się w zakładce 'Folder'. Jeśli nazwa pliku nie będzie się rozpoczynała numerem (zmienna %N), pliki zostaną posortowane alfabetycznie. Mogą także wystąpić problemy w wypadku, jeśli dwa nagrania mają ten sam tytuł.

Znaczenie zmiennych:

%T | Tytuł nagrania
%N | Numer nagrania
%A | Wykonawca płyty lub nagrania
%Y | Rok wydania
%C | Tytuł płyty
%I | Kategoria zgodna z ID3
%B | Kategoria zgodna z CDDB
%D | Wykonawca płyty

Jest pełna swoboda przy tworzeniu nazw plików i folderów, pod warunkiem, że nazwy będą unikalne. Można także do zmiennych dopisać dowolny ciąg znaków. Należy jedynie zdefiniować folder nadrzędny w zakładce 'Folder'.

Oto kilka przykładów zastosowania różnych zmiennych:

%N %T | 04 Stairway To Heaven
%D\%N %T | Led Zeppelin\04 Stairway To Heaven
Moja Muzyka\%D\%C\%N %T | Moja Muzyka\Led Zeppelin\Led Zeppelin IV\04 Stairway To Heaven

Używaj składni dla różnych wykonawców
Jeśli płyta jest zbiorem nagrań różnych wykonawców (kompilacją), można tu określić gdzie mają być kierowane poszczególne nagrania. Zasady są identyczne jak powyżej. Funkcja działa jednak tylko wtedy, gdy zostanie włączony przełącznik 'Kompilacja' w głównym oknie programu lub przy opisywaniu płyty.

Zamień spacje na podkreślenia
Spacje w nazwach plików zostaną zamienione na podkreślenia: 04 Led Zeppelin-Stairway To Heaven -> 04_Led_Zeppelin-Stairway_To_Heaven. Ma to znaczenie w systemach operacyjnych nietolerujących spacji (na przykład DOS).


Opcje EAC'a - Urywek

Omówienie

Ta zakładka służy do definiowania długości fragmentów nagrań i miejsc, z których zostaną wzięte. Umożliwia przygotowanie na przykład krótkich urywków nagrań w celach demonstracyjnych.

Ustawienia

Długość urywka (w sekundach)
Tutaj definiuje się jak długie mają być zgrywane fragmenty nagrań.

Początek urywka w nagraniu (w sekundach)
Sam początek nagrania może o nim nic nie mówić. Tutaj można określić, od którego miejsca w nagraniach będą się zaczynać zgrywane urywki.

Długość zgłośniania (w sekundach)
Długość wyciszania (w sekundach)
Aby uniknąć rozpoczynania i kończenia się urywka z pełną głośnością można ustawić czas zgłośniania i czas ściszania. Nie należy żadnego z pól pozostawić pustego (minimalna wartość to 0), w przeciwnym wypadku pojawi się stosowny komunikat błędu.


Opcje EAC'a - Folder

Ustawienia

Standardowy folder nadrzędny dla zgrywanych nagrań:

Każdorazowo pytaj (domyślnie wskazując ostatnio używany folder)
Program za każdym razem zapyta gdzie mają zostać zgrane nagrania (ze wskazaniem na ostatnią lokalizację).

Używaj tego folderu:
Do gromadzenia plików zostanie użyty folder wybrany tutaj. Najwygodniej jest wpisać partycję i ewentualnie folder np. E: albo D:\Moja muzyka), a resztę (na przykład wykonawców i tytuły płyt) określić na karcie 'Nazwy plików'. Będzie wtedy łatwiej zawiadywać zbiorami.


Opcje EAC'a - Wypalanie

Ustawienia

Zamień wszystkie litery informacji CD-Tekstu na wersaliki
Informacje CD-Tekstu zostaną zmienione na wersaliki (WIELKIE LITERY) i tak wypalone.

Dodawaj nazwę wykonawcy do tytułu nagrania
Informacje CD Tekstu o tytułach nagrań zostaną uzupełnione nazwą wykonawcy. (Niektóre odtwarzacze nie wyświetlają nazwy wykonawcy, lecz tylko same tytuły nagrań. Dzięki tej opcji nazwa wykonawcy staje się częścią składową tytułu, więc będzie wyświetlana razem z nim.)

Wyłącz flagę blokowania kopiowania dodając nagrania do edytora układu płyty
Płyta nie będzie zabezpieczona przed cyfrowym kopiowaniem. Zabezpieczenie działa tylko w stacjonarnych kopiarkach i nie ma znaczenia przy kopiowaniu w komputerze.

Używaj CDRDAO do wypalania w edytorze układu płyty
CDRDAO to program linii poleceń służący do wypalania w trybie DAO płyt audio i z danymi. Tylko w trybie DAO możliwe jest nagranie płyty zawierającej CD-Tekst. Ten tryb pozwala również na dowolne manipulacje długością i zawartością przerw między nagraniami. W przerwie można także ukryć dane, na przykład oklaski czy komentarze. Zestaw komend opisujących płytę zawarty jest w tekstowym pliku TOC, który opisuje jakie dane mają zostać zapisane i umożliwia kontrolę pozycji nagrań, indeksów, przerw oraz informacji subkanałowych. Zamiast pliku TOC, można użyć pliku arkusza dyrektyw

.


Opcje EAC'a - Interfejs

Omówienie

Do poprawnej pracy EAC wymaga obecności w systemie sterowników ASPI (Advanced SCSI Programmer's Interface). Do systemów Windows z rodziny 9x były dołączane i instalowane wraz z systemem, w systemach Windows NT/2000/XP ich nie ma. Co prawda program może pracować na swoim rodzimym interfejsie, ale lepsze rezultaty osiąga ze sterownikami firmy Adaptec (ASPI) lub VOB (obecnie Pinnacle Systems - ASAPI). Jeśli wystąpią problemy z rozpoznawaniem napędów w systemach z rodziny NT/2000/XP, lub program w ogóle nie wykryje napędu - należy pobrać i zainstalować sterowniki menadżera ASPI. Podobnie należy postąpić, gdy napędy wprawdzie widać, ale program nie wyświetla zawartości płyty.

Problemy

Ponieważ występują problemy w Windows XP bardziej zaawansowani użytkownicy mogą spróbować pokusić się o wymuszenie poprawnej pracy sterowników:

1. Sprawdzić zainstalowane komponenty (narzędzie o nazwie ASPICHK dołączane do programu instalacyjnego). Jeśli znajdują się na liście pliki WOWPOST.EXE lub WINASPI.DLL, należy ich poszukać w folderze WINDOWS (łącznie z podfolderami i ukrytymi plikami) i skasować - nie są potrzebne.

2. Zainstalować sterowniki ASPI 4.71 lub nowsze dostępne na stronie ADAPTEC'a używając pliku INSTALL.BAT. Ponieważ wymaga podania parametru najwygodniej jest z menu 'Start' wybrać polecenie 'Uruchom', kliknąć przycisk 'Przeglądaj', znaleźć plik INSTALL.BAT, dopisać odpowiedni parametr poprzedzając go pojedynczą spacją (X86 dla Windows 98/ME/NT/2000, XP32 dla Windows XP 32-bitowego lub XP64 dla Windows XP 64-bitowego) i zatwierdzić klawiszem 'OK'. Wpis w polu uruchom powinien wyglądać na przykład tak: C:\ADAPTEC\ASPI\INSTALL.BAT XP32.

3. Można uruchomić plik reg_xp.exe, który dołączony jest do pakietu instalacyjnego, lecz pewniej jest zmodyfikować rejestr samodzielnie dodając następujące klucze:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ASPI32\Parameters]
"ExcludeMiniports"=""

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ASPI32]
"ErrorControl"=dword:00000001
"Start"=dword:00000002
"Type"=dword:00000001

Zdarza się, że instalacja sterowników nie pwiedzie się lub, mimo zainstalowania najnowszej wesji, program w dalszym ciągu ma kłopoty z napędami. W tej sytuacji może pomóc narzędzie o nazwie ForceASPI (znalezienie go w sieci nie stanowi żadnego problemu).

Jeśli dalej występują problemy należy sprawdzić i ewentualnie spróbować zmienić wartość
"Start"=dword:00000001
na
"Start"=dword:00000002
lub odwrotnie. Po dokonaniu wszystkich zmian trzeba ponownie uruchomić komputer.

Ustawienia

Zainstalowany zewnętrzny interfejs ASPI
Będą używane zewnętrzne sterowniki menadżera ASPI. Najlepszą zgodność zapewniają sterowniki firmy Adaptec, których najnowszą wersję można ściągnąć z jego strony domowej (http://www.adaptec.com/).

Zainstalowany zewnętrzny interfejs ASAPI (z VOB software)
Można użyć alternatywnych sterowników menadżera ASPI dołączanych do pakietu Instant CD/DVD firmy VOB. Od 1 stycznia 2003 VOB stało się częścią Pinnacle Systems GmbH.

Rodzimy interfejs Win32 dla Windows NT/2000/XP
Używany będzie sterownik zawarty w programie.


Opcje napędu

Aby skonfigurować napęd należy go najpierw wybrać z rozwijanej listy znajdującej się pod menu w głównym oknie programu. Następnie w menu 'EAC' kliknąć 'Opcje napędu' (ewentualnie wcisnąć F10). Otworzy się okno z kilkoma kartami.

Można po kolei skonfigurować wszystkie zainstalowane w komputerze napędy (oprócz wirtualnych). Jest to czynność jednorazowa. Przed przystąpieniem do działania dobrze jest do wybranego napędu włożyć płytę audio (i tak program o nią poprosi). Najlepiej gdyby to była standardowa płyta, to znaczy z nagraniami oddzielonymi dwusekundowymi przerwami (więc nie na przykład koncert) i bez żadnych dodatkowych sesji.

Nie ma potrzeby przeprowadzania konfiguracji w ściśle określonej kolejności. Niemniej jednak dobrze jest najpierw wybrać prawidłową komendę odczytu. W tym celu należy przejść do karty 'Napęd' i ręcznie lub automatycznie (używając przycisku 'Wykryj teraz komendę odczytu ustawić właściwą.

Po wprowadzeniu wszystkich zmian należy je zatwierdzić przyciskiem 'OK'. Dobrze jest w tym momencie zamknąć program i uruchomić ponownie.


Opcje napędu - Tryby zgrywania

Omówienie

Jeśli cechy napędu nie są znane lub brak pewności co do ich ustawień - konfigurację najwygodniej rozpocząć od wciśnięcia przycisku 'Wykryj właściwości napędu...'. Program spróbuje automatycznie wykryć podstawowe właściwości urządzenia. Na ten czas należy powstrzymać się od pracy z innymi programami, a najlepiej wszystkie zamknąć, aby nie zafałszować wyników. Wykrywanie może potrwać nawet kilkanaście minut. Jeśli rezultaty pojawiły się błyskawicznie oznacza to, ze test się nie udał i trzeba go powtórzyć. Następnie należy zaaprobować wyniki przyciskiem 'Zastosuj'.

Gdy opcja 'Prześlij wykryte cechy napędu (ale zapytaj o zgodę)' ('Opcje EAC'a', karta Narzędzia') jest włączona zostanie wyświetlona prośba o wysłanie wyników do bazy danych programu, aby inni użytkownicy mogli także z nich skorzystać.

Ustawienia

Tryb bezpieczny z następującymi cechami napędu (zalecany)
Każdy sektor jest odczytywany dwukrotnie, a wyniki porównywane. Gdy wystąpi błąd (odczytu lub synchronizacji) program tak długo ponawia odczyt, aż osiem z szesnastu prób dadzą identyczne wyniki. W zależności od ustawienia opcji 'Dokładność korygowania błędów' szesnastokrotnych cykli podwójnego odczytu może być od jednego do pięciu. Jest tutaj bardzo ważne, aby były użyte właściwe cechy napędu. Ten tryb zgrywania nagrań, choć nie jest najszybszy, daje najlepsze wyniki. Można oczywiście używać szybszych, lecz mimo to warto skonfigurować poprawnie napęd, aby - gdy zajdzie taka konieczność - dało się w każdej chwili przełączyć się na ten tryb pracy, gdy inne okażą się bezradne. Z drugiej strony, jeśli napęd wcale nie potrafi pracować w tym trybie może się okazać, że wykonanie perfekcyjnych kopii będzie niemożliwe.

Napęd zapewnia 'Dokładny strumień'
Ta opcja powinna być włączona, jeśli napęd obsługuje dokładny strumień, co oznacza, że nie wymaga korekty synchronizacji (jitter). Praktycznie wszystkie nowe napędy zapewniają dokładność strumienia.

Napęd buforuje dane audio
Każdy sektor zgrywanego nagrania jest odczytywany dwa razy, a wyniki porównywane. Jeśli próbki nie będą identyczne będzie czytany ponownie, aż do momentu otrzymania satysfakcjonującego rezultatu. Jeśli mimo wielokrotnych ponowień odczytu próbki w dalszym ciągu będą różne - użytkownik zostanie poinformowany o wystąpieniu błędu. Gdy napęd dane audio najpierw wczytuje do pamięci podręcznej, a dopiero stamtąd wysyła do programu - z niej właśnie będą pochodzić kolejne porównywane próbki. Muszą być identyczne, ponieważ nie zostały ponownie odczytane, lecz wysłane te, które były zapisane w buforze. Porównanie dwu tych samych błędnych informacji będzie oczywiście satysfakcjonujące - próbki są takie same, więc błędu nie ma, można przejść dalej. Dlatego ta opcja jest bardzo istotna ze względu na poprawność zgrywania. Jeśli napęd ma pamięć podręczną będzie ona opróżniana, aby do porównania brane były próbki odczytywane bezpośrednio z płyty, a nie z bufora. Spowolni to wyraźnie sam proces zgrywania, ale da pewność poprawności wyników.

Napęd potrafi zwracać informacje o błędach C2
Niektóre nowe napędy potrafią jednocześnie z danymi audio przesyłać informacje o błędach C2 (diagnozowanych na poziomie sprzętowym). Ta informacja sygnalizuje programowi, że coś poszło nie tak przy odczycie. Gdy napęd przesyła informacje program nie musi już odczytywać dwukrotnie każdego sektora (co spowalnia zgrywanie), lecz opierając się na otrzymywanych informacjach koncentrować tylko na tych miejscach, których wadliwość została zasygnalizowana.

Tryb paranoidalny (nie zalecany)
Starszy sposób zgrywania, charakteryzujący się ponawianiem odczytu sektorów w małych blokach aż do skutku, czyli do uzyskania identycznych wyników. W skrajnych przypadkach może to doprowadzić nawet do przegrzania się i awarii napędu.

Tryb szybki
Standardowy tryb synchronizowany, zwany w innych programach "normalnym", "synchronizowanym" lub podobnie. Sektory są synchronizowane z dwoma blokami z dwudziestu trzech.

Tryb ciągły
Najszybszy z trybów, zwany burst, działający bez żadnej korekcji błędów i synchronizacji sektorów. Zapobiega powstawaniu przerw między odczytem i zapisem, gdyż jednocześnie z odczytem kolejnego sektora zapisywany jest poprzedni. Umożliwia osiągnięcie maksymalnej szybkości. Jeśli strumień zostanie przerwany w raporcie zostanie to zasygnalizowane. Jednak jest to tylko teoria - skoro nie ma w tym trybie żadnej korekcji błędów wiele z nich może zostać przeoczonych.

Przyciski

Wykryj właściwości napędu...
Ta funkcja służy do wykrywania wszystkich tych cech napędu, których prawidłowe ustawienie jest warunkiem niezbędnym do otrzymywania bezbłędnych kopii w trybie pewnym.

Zweryfikuj zwracanie błędów C2...
Niektóre urządzenia deklarują obsługę raportowania o wystąpieniu błędów C2, lecz w rzeczywistości tego nie robią. A jest to bardzo istotne, ponieważ włączenie tej opcji dla napędu jej nie obsługującego uniemożliwi prawidłową reakcję w razie wystąpienia błędu. W celu dokładnego sprawdzenia jaka jest rzeczywistość należy włożyć do napędu najbardziej porysowaną i zabrudzoną płytę jaką uda się znaleźć, ponieważ na nowej, nieuszkodzonej (teoretycznie) nie występują błędy C2. Jeśli zostanie zgłoszony błąd, co - w zależności od miejsca jego wystąpienia - może chwilę potrwać, można mieć pewność, że napęd faktycznie prawidłowo obsługuje tę funkcję.

Problemy

Cała konfiguracja nie jest tak skomplikowana jak się wydaje na pierwszy rzut oka. W zasadzie wszystko można zrobić automatycznie. Bardzo rzadko program nie potrafi prawidłowo wykryć jakimi cechami charakteryzuje się napęd. Lecz jeśli akurat tak się zdarzy nie pozostaje nic innego jak ręczna konfiguracja. Można spróbować poszukać napędu na Liście zgłaszanych przez użytkowników cech napędów. Jeśli napędu na niej nie ma, można jeszcze spróbować wejść na stronę domową Exact Audio Copy i odwiedzić jego forum dyskusyjne, albo zapisać się na listę dyskusyjną. Tysiące ludzi będzie próbowało pomóc.


Opcje napędu - Odczyt

Omówienie

Na tej karcie ustawiana jest komenda odczytu, której program będzie używał przy czytaniu płyt audio. W zasadzie konfiguracja od tego powinna zostać rozpoczęta. Najwygodniej jest pomóc sobie przyciskiem 'Wykryj teraz komendę odczytu'. Dzięki temu EAC będzie używał poprawnego ustawienia po każdym uruchomieniu.

Problemy

Bardzo rzadko zdarza się, ze automatyczne wykrywanie zawiedzie. W tej sytuacji nie pozostaje nic innego jak samemu dokonać wyboru komendy odczytu. Można także spróbować zajrzeć na stronę domową Exact Audio Copy i jego forum dyskusyjne albo zapisać się na listę dyskusyjną. Tysiące ludzi będzie próbowało pomóc. Z kolei jeśli komenda odczytu została samodzielnie poprawnie ustawiona, a napędu nie ma na liście - można pomóc innym wysyłając informacje do bazy danych.

Ustawienia

Poniższe dwa ustawienia są bardzo rzadko używane. Lepiej ich nie ruszać bez wyraźnej potrzeby:

Kolejność bajtów "Big Endian" (Motorola)
Zdarzają się (bardzo rzadko) napędy zwracające próbki ze złą kolejnością bajtów. 16 bitowa próbka jest podzielona na dwa bajty, które są zamieniane miejscami i w takiej postaci przesłane. Jeśli zgrane nagrania brzmią jak czysty szum należy spróbować włączyć tę opcję.

Zamień miejscami kanały
Czasami napędy zamieniają miejscami prawy kanał z lewym. Ta opcja pozwala na usunięcie tej niedogodności dla wszystkich zgrywanych nagrań.

Rozpędź napęd przed rozpoczęciem zgrywania
Niektóre napędy poprawnie wysyłają dane dopiero po osiągnięciu pełnej szybkości. Jeśli zniekształcone są początki zgranych nagrań należy włączyć tę opcję. Napęd będzie rozpędzany przed rozpoczęciem zgrywania każdego nagrania.


Opcje napędu - Przesunięcie / Szybkość

Omówienie

Płyta kompaktowa odtwarzana jest od środka na zewnątrz, ze stałą szybkością liniową. Czyli prędkość obrotowa maleje w miarę zbliżania się do zewnętrznej krawędzi .

Rozpoczyna ją spis zawartości (Table Of Contents - TOC), który zawiera wszystkie informacje o pozycjach poszczególnych nagrań i ich tytuły (CD-Tekst). Potem następuje obszar wiodący (LeadIn) oddzielony dwusekundową przerwą od nagrań, a kończy obszar zamykający (LeadOut).

Teoretycznie napęd powinien rozpoczynać odczyt dokładnie od początku płyty, czyli z pozycji 00:00:00,000 (minuty:sekundy:ramki,próbki). Jednak w praktyce tak nie jest. Poniższy rysunek poglądowo ilustruje problem - dla uproszczenia na płycie są tylko dwa nagrania. W górnej połowie mamy strukturę płyty, którą odtwarza napęd.

Widać, że nastąpiło przesunięcie - odtwarzanie zaczyna się za opóźnieniem. Wynika z tego, że nie uda się stworzyć idealnej kopii, ponieważ będzie brakować małego fragmentu początku pierwszego nagrania. A pierwsze nagranie będzie z kolei zawierało początkowy fragment drugiego. Natomiast drugie - jeśli napęd nie potrafi nadczytywać z obszaru LeadOut, będzie o tyle samo krótsze. Na drugim rysunku z kolei jest zobrazowana sytuacja odwrotna - odczyt zaczyna się zbyt wcześnie. Do początku pierwszego nagrania dodany jest fragment przerwy oddzielającej je od obszaru LeadIn, natomiast odczyt drugiego skończy się za wcześnie.

Jakiego rzędu są to wartości? Jedna próbka to 1/44100 sekundy. Więc przesunięcie o 2000 próbek to różnica wynosząca dokładnie 0,045 sekundy czyli 45 milisekund. Inaczej - w standardowym sygnale o częstotliwości 1000 Hz będzie brakować 45 cykli, czyli - bardziej optymistycznie - pozostanie 955. Dla porównania - mrugnięcie okiem trwa około 100 ms.

Do wyliczania i korygowania przesunięcia służą specjalne płyty referencyjne. Jednak posiadanie któregoś tytułu z listy to jeszcze nie wszystko. Płyta musi pochodzić z tej samej partii, czyli musi się zgadzać kod identyfikacyjny (czyli numer tłoczenia). Można go znaleźć po nagranej stronie na wewnętrznym, przeważnie przezroczystym, pierścieniu.

W celu określenia jakie przesunięcie wnosi posiadany napęd należy włożyć do niego jedną z płyt referencyjnych i kliknąć przycisk 'Wyznacz wartość przesunięcia odczytu...'. Liczba dodatnia oznacza, że odczyt zaczyna się zbyt wcześnie, więc należy go opóźnić. W polu "Nadczytywanie" znajduje się informacja o tym, z jakich obszarów (LeadIn lub LeadOut) napęd potrafi nadczytywać, czyli dodawać ich fragmenty do brakujących części nagrań.

To, co zostało dotychczas powiedziane na temat odczytu dotyczy także zapisu. On również nie jest stały i różne modele nagrywarek starują z różnych pozycji. Dlatego należy taże skorygować i zapis. Służy do tego funkcja 'Utwórz płytę testową przesunięcia', znajdująca się na karcie 'Zapis'. Do utworzenia płyty testowej można użyć CD-RW. Gdy jest gotowa należy ją włożyć do napędu, w którym testowana była płyta referencyjna i postępować dokładnie tak samo (klikając przycisk 'Wyznacz wartość przesunięcia odczytu...') jak przy korzystaniu z płyty referencyjnej. Otrzymany wynik to "Wspólna dla odczytu/zapisu korekta przesunięcia" (należy go wpisać w to pole). Od niego trzeba odjąć otrzymaną wcześniej przy teście z płytą referencyjną wartość przesunięcia odczytu i wynik wpisać w pole "Przesunięcie zapisywanych próbek" w zakładce 'Zapis'

przesunięcie zapisu = wspólna dla odczytu/zapisu korekta przesunięcia - korekta przesunięcia odczytu

Ustawienia

Koryguj przesunięcie odczytu
Pozwola na bezbłędne i zgodne z oryginałem kopiowanie nagrań na dysk. Druga opcja

Użyj wspólnej dla odczytu/zapisu korekty przesunięcia
pozwoli na odsłuch tej płyty jako prawie (bo będzie brakować próbek wynikających z różnicy przesunięcia odczytu i zapisu) wiernej kopii tylko na jednym konkretnym urządzeniu przy wypalaniu za pomocą Exact Audio Copy. Dla innych urządzeń oczywiście taka płyta nie będzie w 100% zgodna z oryginałem - przesunięty został przecież zapis dostosowując go do konkretnego urządzenia.

Inna sytuacja wystąpi, gdy do wypalanie będzie użyty zewnętrzny program. Wtedy, aby uzyskać zgodny wynik, należy tak zgrywać nagrania, aby uwzględnić przesunięcie wprowadzone przez nagrywarkę. W celu otrzymania dokładnej wartości korekty należy postąpić następująco: Wyzerować "Wartość korekty przesunięcia odczytu", czyli wpisać 0. Zgrać nagranie nazywając plik na przykład "nagranie wzorcowe.wav". Następnie wypalić to nagranie preferowanym programem. Po wypaleniu zgrać je z takimi samymi zerowymi ustawieniami wartości korekty przesunięcia odczytu, tym razem nazywając plik na przykład "nagranie wypalone.wav". Z menu 'Narzędzia' wybrać 'Porównaj pliki wav...'. wyniki porównania pomogą w wyliczeniu właściwego przesunięcia: jeśli brakuje próbek lub są powtórzone w nagraniu wzorcowym - korekta przesunięcia będzie dodatnia, jeśli w wypalonym - ujemna. Ta wartość to "Wspólna dla odczytu/zapisu korekta przesunięcia". Aby wyliczyć przesunięcie odczytu należy od niej odjąć znalezioną wcześniej wartość korekty zapisu:

korekta przesunięcia odczytu = wspólna dla odczytu/zapisu korekta przesunięcia - przesunięcie zapisu

Wyliczoną wartość trzeba wpisać w pole "Wartość korekty przesunięcia odczytu". Uwaga: Włączenie korekty przesunięcia odczytu może drastycznie spowolnić zgrywanie, a rezygnacja z korekcji błędów skutkować nieakceptowalną jakością kopii.

Nadczytuj w obszarach LeadIn i LeadOut
Czy napęd potrafi odczytywać w obu tych obszarach, czy w jednym z nich można określić testując przesunięcie. Natomiast włączenie jej dla urządzenia nie mającego tych właściwości będzie skutkować pojawianiem się błędów. Ta funkcja jest jedną z alternatywnych wymaganych dla poprawnej pracy AccurateRip.

Wybór szybkości
Można spróbować tutaj ograniczyć maksymalną szybkość odczytu. Jednak nie wszystkie urządzenia pozwalają na to pozwalają. Przeważnie wartość tutaj wpisana jest ignorowana, a napęd automatycznie zwalnia w obszarach, w których napotkał problemy, po czym powinien przyspieszyć.

Zezwalaj na redukcję szybkości w trakcie zgrywania
Program może ograniczyć szybkość zgrywania, gdy natrafi na obszar zawierający błędy. Ta opcja pozwala na ponowne przyspieszenie po opuszczeniu uszkodzonego obszaru, lecz nie wszystkie napędy to potrafią.

Napęd potrafi czytać CD-Tekst
Większość nowych napędów potrafi odczytywać CD-Tekst, jednak praktycznie na żadnej tłoczonej płycie go nie ma.


Opcje napędu - Wykrywanie przerw

Omówienie

Standardowo przerwy mają około 2 sekundy długości i oddzielają poszczególne nagrania na płycie. Należy pamiętać, że znajdują się przed nagraniem, a nie - zgodnie z logiką - po nim. Stąd po angielsku "pre-gap". Program wykrywa je czytając informacje z subkanałów. Jeśli napęd tego nie potrafi detekcja nie będzie możliwa.

Ustawienia

Program stosuje trzy warianty wykrywania -

Sposób wyszukiwania przerw/indeksów

- i trzy poziomy dokładności

Dokładność wykrywania

Wariant "A" jest najszybszy, a "Pobieżna" oznacza, że informacja o pozycji przerwy jest czytana tylko raz.

Poprawne skonfigurowanie będzie wymagało trochę czasu, ponieważ odbywa się metodą prób i błędów: po wybraniu jednego z wariantów "A", "B" lub "C" i oczekiwanej dokładności czas trwania operacji powinien mieścić się w rozsądnych granicach, a długości przerw muszą być różne od zera. Do konfiguracji należy więc użyć standardowej płyty audio, to znaczy z nagraniami oddzielanymi przerwami (czyli nie na przykład koncertowych, czy wieloczęściowych suit).

Uwaga: Tryb B, jako jedyny, pozwala na użycie funkcji ręcznego wykrywania układu płyty ('Zmiany w TOC', menu 'Akcja'), którą można się posłużyć przy uszkodzonych płytach wyświetlających złe pozycje (czasy rozpoczęcia, długości) nagrań albo wtedy gdy utwory zgłaszają się jako dane. Jeśli napęd nie pracuje w tym trybie - nie da się zgrywać takich płyt.


Opcje napędu - Zapis

Ta zakładka pojawia się tylko wtedy, gdy w polu wyboru napędu, w głównym oknie programu, wybrana jest nagrywarka.

Ustawienia

Po zakończeniu wypalania
zresetuj nagrywarkę wysuwając i wsuwając szufladkę
Po wypaleniu lub przeprowadzeniu testu szufladka zostanie wysunięta i wsunięta w celu odświeżenia zawartości płyty. Zdarza się bowiem, że system operacyjny nie rozpoznaje, że w nagrywarce jest już płyta z danymi, a nie pusty nośnik, lub że po teście wypalania płyta nadal jest pusta. Jeśli tak się dzieje należy włączyć tę opcję.

tylko wysuń szufladkę
Po wypaleniu płyty szufladka zostanie wysunięta.

nie wysuwaj szufladki
Szufladka po wypaleniu nie zostanie wysunięta. Na wszelki wypadek lepiej wybrać opcję 'zresetuj nagrywarkę wysuwając i wsuwając szufladkę', ponieważ efekt końcowy będzie ten sam, a nagrywarka zostanie zresetowana. System operacyjny bowiem czasami nie rozpoznaje, że zawartość płyty uległa zmianie.

Nagrywarka potrafi zapisywać kody UPC/ISRC
UPC i ISRC są kodami przydzielanymi dla profesjonalnie nagrywanych płyt. W praktyce amatorskiej nie mają żadnego znaczenia. Do sprawdzania czy nagrywarka może zapisywać te kody służy przycisk 'Wykryj cechy zapisu...'

Nagrywarka potrafi zapisywać CD-Tekst
Większość nowych nagrywarek potrafi zapisywać CD-Tekst. Należy odpowiednio przygotować projekt płyty opatrując nagrania tytułami, podać tytuł płyty i wykonawcę. Do sprawdzania, czy nagrywarka obsługuje tę funkcję służy przycisk 'Wykryj cechy zapisu...'

Przyciski

Utwórz płytę testową przesunięcia
Ten przycisk służy do tworzenia płyty testowej dla wyznaczania przesunięcia zapisu. Szczegóły znajdują się przy opisie zakładki 'Przesunięcie / Szybkość'.

Wykryj cechy zapisu...
Wykrywanie cech zapisu wymaga włożenia czystego nośnika. Program sprawdzi, czy nagrywarka potrafi zapisywać kody UPC/ISRC i CD-Tekst. Jeśli program się zawiesi lub wyświetli komunikat: "Błąd zapisu! Testowane urządzenie gotowe: Brak dodatkowych rozsądnych informacji" - oznacza to, że nagrywarka nie jest (jeszcze) obsługiwana.


Opcje kompresji

Kilka słów na temat kompresji

Przyjęto, że parametry oddające wiernie dźwięk rzeczywisty cyfrowo to częstotliwość próbkowania wynosząca 44,1 kHz oraz 16-bitowa rozdzielczość, które pozwalają na uzyskanie pasma sygnału do około 20-22 kHz i dynamiki na poziomie 100 dB (lub 96 dB w zależności od sposobu liczenia). Nie do końca odpowiada to dynamice słuchu ludzkiego, jednak umożliwia przesunięcie szumów do poziomu, przy którym są praktycznie niesłyszalne. Przepływność bitów wynosi 1 411 200 bitów/sekundę, czyli nie do przyjęcia do transmisji przez Internet. Najprostszym sposobem kompresji dźwięku jest więc ograniczenie jego częstotliwości i rozdzielczości. Jednak obniżanie wartości tych parametrów bardzo niekorzystnie wpływa na jakość dźwięku (ilustruje to poniższy rysunek).

Ograniczenie częstotliwości próbkowania zawęża pasmo przenoszenia sygnału (pasmo przenoszenia to mniej więcej połowa częstotliwości próbkowania). Brak wyższych harmonicznych objawia się przy odtwarzaniu efektem podobnym do dźwięku wydawanego przez radio na falach długich lub rozmowę telefoniczną (chodzi oczywiście o głuche i płaskie brzmienie, a nie o szumy i trzaski). Z kolei zmniejszenie rozdzielczości zmniejsza dynamikę dźwięku, co uniemożliwia prawidłowe odtworzenie na przykład koncertu fortepianowego - nierozróżniane są subtelne różnice w amplitudzie dźwięku. Dodatkowym efektem jest znaczne podniesienie poziomu szumu.

W wielkim uproszczeniu - wszystkie nowoczesne kompresory stratne, takie jak: MP3, VQF, OGG itp., działają na tej samej zasadzie - wycinają z sygnału wszystko, co teoretycznie jest niesłyszalne. Pozwala to na osiągnięcie dużo mniejszych plików. Trzeba sobie jednak zdawać sprawę, że odtworzenie oryginału nie jest już możliwe. EAC pozwala na obsługę praktycznie dowolnego kodeka linii poleceń.

Opcje

Po wybraniu w menu 'EAC' -> 'Opcje kompresji' (ewentualnie wciśnięciu F11) otworzy się okno z kilkoma kartami.

Należy pamiętać, że to nie Exact Audio Copy kompresuje nagrania. lecz wywołuje zewnętrzny program, któremu podstawia parametry zdefiniowane tutaj. Więc aby skompresować płytę czy poszczególne nagrania z niej należy zaopatrzyć się w preferowany kodek i przygotować mu odpowiedni schemat.


Opcje kompresji - Format audio

Omówienie

Exact Audio Copy potrafi korzystać z zewnętrznych kompresorów uruchamianych z linii poleceń. Pewnym utrudnieniem jest to, że trzeba konfigurować program dla każdego kodera z osobna, ponieważ ustawienia nie są ujednolicone. Aby za każdym razem nie robić tego na nowo można skorzystać z funkcji 'Profile' (Menu 'EAC' lub pasek stanu).

Opcje na tej karcie staną się dostępne tylko wtedy, gdy wyłączony jest przełącznik 'Używaj zewnętrznego programu do kompresji' znajdujący się na karcie 'Zewnętrzna kompresja'.

Ustawienia

Format audio
Windows obsługuje różne techniki kompresji w formacie wav. Kompresja jest wykonywana przez kodeki, które mogą być łatwo dodawane i usuwane z systemu. EAC potrafi także samodzielnie współpracować z bibliotekami dll wyglądającymi jak kodeki (na przykład Lame.dll, BladeEnc.dll).

Format próbki
Pole wyboru pozwalające określić jakość i typ kompresji.

Dodawaj znacznik ID3
Niektóre formaty umożliwiają przechowywanie informacji na temat wykonawcy, tytułu nagrania itp. wewnątrz pliku. Wiele odtwarzaczy odczytuje i wyświetla je więc nie ma znaczenia nazwa pliku.

Nie zapisuj nagłówka wav w pliku
W przypadku niektórych formatów Windows dostarcza kodeki, mogące kompresować i odtwarzać pliki tylko wtedy, gdy posiadają nagłówek pliku WAV oraz odpowiednie rozszerzenie. Nie jest to konieczne w przypadku MP3. Natomiast plik WAV bez nagłówka zawierałby wyłącznie dane i mógłby nie zostać rozpoznany przez koder.

Wysoka jakość (wolniej) - .
Niska jakość (szybciej) -
Wiele kodeków Windows pozwala na wybór między jakością a szybkością.

Rozszerzenie dla plików bez nagłówka
Po włączeniu opcji "Nie zapisuj nagłówka wav w pliku" tu należy podać rozszerzenie. Nieskompresowane pliki bez nagłówka mają zazwyczaj rozszerzenie .raw.


Opcje kompresji - Zewnętrzna kompresja

Ustawienia

Używaj zewnętrznego programu do kompresji
Program potrafi obsługiwać kodery wywoływane z linii poleceń i przesyłać im żądane parametry.

Schemat podstawianych parametrów
Wiele koderów wymaga specjalnego sposobu przesyłanie parametrów. Tutaj należy wybrać preferowany.

Używaj rozszerzenia pliku
Jeśli zdefiniowano własny koder linii poleceń może zachodzić konieczność podania odpowiedniego rozszerzenia. Dzięki temu możliwe jest tworzenie dowolnego istniejącego i przyszłego formatu pliku.

Program, łącznie ze ścieżką, użyty do kompresji
Miejsce (ścieżkę), gdzie znajduje się kodek.

Dodatkowe opcje linii poleceń
Jeśli znane są polecenia dla kodera i jego parametry (na przykład nowe możliwości lub dodatkowe ustawienia jakości) można je tutaj podać. Ten wpis ma pierwszeństwo przed innym ustawieniami. Pole można pozostać puste, jeśli wybrano koder z listy. Dla kodera Lame znajdujące się tu domyślne wartości blokują wybór przepływności bitów z rozwijanej listy 'Przepływność bitów'.

Przepływność bitów: xxx
Tu wybieramy przepływność bitów, od której zależy jakość i wielkość pliku wynikowego.

Skasuj plik wav po zakończeniu kompresji
Program najpierw zgrywa nagrania na dysk w postaci nieskompresowanych plików wav, następnie przesyła je do kodera. Po skompresowaniu można wyjściowe pliki skasować lub pozostawić.

Używaj sprawdzania sumy kontrolnej CRC
Niektóre kodery potrafią dodawać informację o sumie kontrolnej skompresowanych plików, która pozwala zweryfikować ich spójność. Nie wszystkie odtwarzacze z tego korzystają, z kolei a niektóre kodery podają nieprawidłowe dane.

Dodawaj znacznik ID3
Niektóre formaty umożliwiają przechowywanie informacji na temat wykonawcy, tytułu nagrania itp. wewnątrz pliku. Wiele odtwarzaczy odczytuje i wyświetla je więc nie ma znaczenia nazwa pliku.

Sprawdzaj kod zwrotny zewnętrznego programu
Jeśli kodek potrafi zwracać kod błędu zostanie wywołane okno ostrzegawcze, pozwalające zorientować się, że coś poszło nie tak podczas kompresji.

Wysoka jakość
Niska jakość
Wiele kodeków Windows pozwala na wybór między jakością kosztem szybkości i odwrotnie.


Opcje kompresji - Przesunięcie

Omówienie

Zobacz omówienie problemu znajdujące się na karcie 'Przesunięcie / szybkość' 'Opcji EAC'a'.

Ustawienia

Używaj korekty przesunięcia dla kodowania i dekodowania
Niektóre kodery dodają do kompresowanych plików błąd przesunięcia tak, że na początku nagrania powstaje kilka pustych próbek, a na końcu tyle samo (lub więcej) brakuje. Jest to szczególnie niepożądane przy nagraniach koncertowych, które nie powinny zawierać żadnych przerw. Jednak detekcja pozycji używa domyślnie zainstalowanego kodera do jej wyznaczania dla wybranego dekodera, który niekoniecznie jest tym samym. Jeśli na przykład użyto kodera Lame i dekodera Frauenhofera, EAC wykryje i zastosuje różnicę pozycji między nimi. Jednak jeśli do odtwarzania zostanie użyty dekodera Lame - pozycja nie będzie prawidłowa.

Wykryj przesunięcie...
Przycisk służący do wykrywania różnicy między przesunięciem aktualnie wybranego kodeka lub zewnętrznego kodera a dekoderem.

Używaj kodeka linii poleceń LAME dla kodowania i dekodowania plików mp3
Przeważnie w systemie znajduje się okrojona wersja kodeka Fraunhofer MP3 Codec. Zamiast niego można używać LAME lub dowolnego innego. Plik kodeka musi znajdować się w folderze programu.

Składnia pola komentarza ID3 przy zgrywaniu
Niektóre formaty umożliwiają przechowywanie informacji na temat wykonawcy, tytułu nagrania itp. wewnątrz pliku. Wiele odtwarzaczy odczytuje i wyświetla je więc nie ma znaczenia nazwa pliku.

Wpisz "Utwór <numer_nagrania>" w polu komentarza znacznika ID3
Do pola komentarza znacznik ID3 można dołączać informację o numerze nagrania.

Wpisz ID freedb w polu komentarza znacznika ID3
Włączenie tej opcji pozwoli na uzyskanie informacji o płycie, z której pochodzi nagranie. Identyfikator zostanie zapisany w polu komentarza w postaci ośmiocyfrowej liczby szesnastkowej.

Wpisz sumę kontrolną w polu komentarza znacznika ID3
EAC wpisze sumę kontrolną nagrań w pole komentarza tylko wtedy, gdy był odczytywany z korektą pozycji lub za pomocą tego samego modelu napędu. To będzie suma kontrolna pliku wav, a nie skompresowanego!

Wpisz następujący tekst w polu komentarza znacznika ID3
Do każdego tworzonego pliku można dodać jednobrzmiąca informację (na przykład adres strony internetowej, poczty lub krótki komentarz). Dla ID3 v1.1 to maksymalnie 29 znaków, a dla ID3 v1.0 - 30.


Opcje kompresji - Znacznik ID3

Ustawienia

Używaj znaczników ID3 V1.1 zamiast ID3 V1.0
Nowy format znaczników ID3 umożliwia podanie informacji o numerze nagrania.

Dodatkowo wpisuj znaczniki ID3 V2 używając dopełnienia do xx kB
W przeciwieństwie do ID3 v1.x nowa wersja znacznika, 2.x, dodaje komentarz na początku pliku. Może to nie być zgodne ze starszymi wersjami koderów i dekoderów. Nie należy również stosować ID3 V2 w przypadku kompresji do formatów innych, niż MP3. Znacznik ID3 v2.x pozwala na wprowadzenie wielu różnorodnych informacji, lecz EAC nie obsługuje ich jeszcze. Ponieważ są zapisywane na początku pliku trudno jest je później zwiększyć. Można więc zarezerwować trochę miejsca dla ewentualnych modyfikacji - domyślne 4 kB w zupełności wystarczą do tego celu.

Używaj znaczników ID3 V2.4.0 zamiast ID3 V2.3.0
Nie wszystkie dekodery obsługują znaczniki w najnowszej wersji 2.4.0, więc informacje mogą być wyświetlane nieprawidłowo albo wcale.

Używaj formatu numerów nagrań w postaci xx/yy w znacznikach ID3V2 (np. 01/16)
Zazwyczaj zarówno w znacznikach ID3V2 jak i ID3V1 numery nagrań określają kolejne miejsce zajmowane przez nie na płycie. Znaczniki ID3V2 pozwalają na dodawanie informacji nie tylko o tym, które w kolejności było określone nagranie, ale także ile ich było na płycie, z której pochodziło. Większość programów wyświetla tę informację w postaci: "numer bieżącego nagrania/liczba nagrań na płycie."

Tworzenie nazw plików ze znaczników ID3
Znaczenie poszczególnych zmiennych jest następujące:

%T | Tytuł nagrania (obowiązkowy)
%A | Wykonawca płyty lub nagrania
%Y | Rok wydania
%L | Tytuł płyty
%C | Komentarz
%I | Rodzaj muzyki ID3
%N | Numer nagrania (przy użyciu znacznika ID3 v1.1)


Opcje kompresji - LAME DLL

Ustawienia

Tryb wyjściowy
Wybierać można między stereo, joint stereo, podwójnym kanałem i wymuszonym mono. Jeśli w trybie joint stereo pojawią się zniekształcenia w skompresowanym pliku - nie pomoże podwyższenie przepływności bitów.

Jakość
Jakość kompresji.

Maksymalna przepływność bitów przy VBR
Tutaj należy podać jaka ma być górna granica przepływności bitów w trybie VBR.

Używaj trybu VBR z jakością x
Tryb VBR pozwala na otrzymanie mniejszego pliku w porównaniu ze skompresowanym ze stałą przepływnością bez pogorszenia jakości. Przy jakości 0 osiągnięcie maksymalnej przepływności nastąpi bardzo szybko, natomiast przy 9 pozostanie w okolicach wartości bazowej.

Używaj trybu ABR ze średnią xxx
Stosowanie trybu ABR może w niektórych przypadkach powodować powstanie słyszalnych skoków jakości. Z drugiej strony pozwala z góry określić rozmiar wynikowego pliku.

Wstaw sumę kontrolną CRC
Można dodawać do wszystkich kodowanych plików informację o ich sumie kontrolnej, w celu weryfikacji ich spójności. Niestety, wczesne kodeki błędnie ją wyliczały, więc jako bezużyteczna bywa ignorowana przez odtwarzacze. Poza tym nie pozwala na naprawę pliku, stanowi jedynie informację, że jest uszkodzony.

Wpisz nagłówek Xing VBR przy kodowaniu VBR
Koder może zapisać nagłówek VBR, pozwalający niektórym odtwarzaczom prawidłowo wykryć zastosowany tryb kompresji.


Opcje kompresji - GOGO DLL

Ustawienia

Tryb wyjściowy
Można wybrać stereo, joint stereo, podwójnym kanałem, wymuszonym mono oraz mid/side stereo.

Ustawienia emfazy
Emfaza to uwypuklenie w trakcie nagrywania wysokich częstotliwości (preemfaza) i osłabienie ich podczas odtwarzania (deemfaza). Funkcja praktycznie nie stosowana. To ustawienie wstawia flagę emfazy do pliku. Jeśli w wyjściowym pliku PCM stosowany był któryś z typów preemfazy, przy odtwarzaniu zostanie odtworzony pierwotny przebieg sygnału. Większość dekoderów ignoruje jednak tę flagę.

Liczba procesorów
W systemach wieloprocesorowych można podzielić kompresję na kilka wątków obsługiwanych przez poszczególne procesory. Znacznie przyspieszy to cały proces.

Tryb VBR z jakością: x
Tryb VBR pozwala na otrzymanie mniejszego pliku w porównaniu ze skompresowanym ze stałą przepływnością bez pogorszenia jakości. Przy jakości 0 osiągnięcie maksymalnej przepływności nastąpi bardzo szybko, natomiast przy 9 pozostanie w okolicach wartości bazowej.

Stosuj psychoakustykę
Kodery GoGo stosują algorytmy psychoakustyczne poprawiające jakość zakodowanego dźwięku.

Wyłącz filtr dolnoprzepustowy
Filtr dolnoprzepustowy obcina częstotliwości leżące powyżej około 17 kHz.


Opcje freedb / bazy danych

Omówienie

EAC pozwala na pobieranie informacji o tytule płyty, wykonawcy, tytułach nagrań z bazy danych freedb. Nie obsługuje komercyjnej CDDB. Aby móc korzystać z tego udogodnienia należy poprawnie skonfigurować połączenia internetowe. Do programu dołączona jest (na początku pusta) wewnętrzna baza danych, którą także tutaj się konfiguruje.

Konfiguracja

Konfiguracja nie jest skomplikowana. Karta 'freedb' służy do definiowania połączenia z internetową bazą danych. W polu 'Twój adres emall' należy (koniecznie!) podać adres poczty elektronicznej i wybrać 'Serwer Freedb' oraz - ewentualnie - skonfigurować serwer proxy (w tym wypadku po szczegółowe informacje należy się zwrócić do administratora sieci). Jeśli program ma kłopoty z połączeniem, przydatna staje się funkcja 'Pobierz listę aktywnych serwerów freedb'. Po pobraniu wystarczy wskazać dowolny serwer i po kłopocie. Gdy i to nie pomoże trzeba próbować kolejno wybierać adresy z rozwijanej listy, aż znajdzie się taki, który zadziała. Można też całą tę procedurę zautomatyzować włączając funkcję 'Przy błędzie połączenia ponów zapytanie używając innego serwera z listy'.

Aby EAC automatycznie łączył się z bazą danych po włożeniu płyty, która nie zawiera informacji CD-Tekstu i nie ma jej w lokalnej bazie danych programu, należy w menu 'EAC', 'Opcje EAC'a', na karcie 'Ogólne' włączyć opcję 'Dla nieznanych płyt' i wybrać 'automatycznie połącz się z bazą danych freedb'.

Na karcie 'Lokalna freedb' określana jest ścieżka i format plików lokalnej bazy freedb znajdującej się na dysku twardym, a karta 'Eksport' służy do definiowania postaci eksportowanych wpisów (rekordów) z wewnętrznej bazy danych.

Jeśli w bazie danych nie ma informacji o płycie można samodzielnie je wprowadzić, a następnie wysłać (menu 'Baza danych' -> 'Wyślij informacje o płycie do freedb' lub ikona [image]). Należy jedynie pamiętać, by podać w miarę sensowny rodzaj muzyki (inaczej EAC odmówi wysyłki) z rozwijanej listy.

Jeśli występują problemy z połączeniem się z freedb można spróbować skorzystać z przełącznika linii poleceń -http1.1. Należy go dodać w 'Eelemencie docelowym' właściwości skrótu. Poniższy obrazek rozwieje wszelkie wątpliwości:


Opcje edytora WAV

Edytor obsługuje tylko nieskompresowane pliki wav. Stosować filtry i efekty należy z rozwagą i umiarem, ponieważ rezultaty mogą być zaskakujące i nie zawsze oczekiwane. Można w nim ręcznie poprawiać kształt przebiegu (modyfikacja kształtu krzywej jest możliwa po dużym powiększeniu wybranego fragmentu), a także usuwać składową stałą z sygnału.

Edytor wywoływany jest z menu 'Narzędzia', 'Edytuj plik wav...'.


Opcje edytora WAV - Edytor

Ustawienia

W czasie odtwarzania podążaj za kursorem
Przebieg (po powiększeniu) będzie przewijany w miarę odtwarzania, a widok będzie cały czas środkowany na kursorze.

Twórz plik wartości szczytowych na dysku
Program może tworzyć i zapisywać na dysku plik zawierający informacje o wartościach szczytowych sygnału, co wydatnie przyspiesza ponowne wczytanie (wiele programów robi to bez pytania), gdyż nie wymaga ponownego skanowania.

Dubluj kanały przy odtwarzaniu jednego
Można zaznaczać, edytować i odtwarzać pojedynczy kanał. Wtedy tylko on jest słyszalny - w drugim będzie cisza. Ta opcja pozwala na dwukanałowe odtwarzanie jednego z kanałów.

Używaj pamięci operacyjnej do przechowywania tymczasowych danych
Zamiast na dysku twardym tymczasowe pliki tymczasowe mogą być tworzone i przechowywane w pamięci RAM. Oczywiście komputer musi być wyposażony w odpowiednią jej ilość.

Używaj tymczasowego pliku na dysku
Plik tymczasowy będzie zapisywany na dysku twardym w miejscu, do którego ścieżkę należy podać w polu 'Ścieżka dla pliku temp'.

Pozwalaj cofać zmiany
Pliki muzyczne zajmują bardzo dużo miejsca. Każda wprowadzona modyfikacja pochłania go coraz więcej. Jeśli komputer nie jest wyposażony w dyski twarde o dostatecznie dużej pojemności miejsca bardzo szybko zabraknie. Dzięki tej opcji każdą nieprzemyślaną lub nie spełniającą oczekiwań modyfikację można cofnąć. W polu 'Ścieżka dla pliku cofania' należy podać dysk lub folder mający najwięcej wolnego miejsca.


Opcje edytora WAV - Porównywanie

Ustawienie

Określaj różnice bardziej dokładnie
Porównywanie plików może być mniej lub bardziej dokładne. Zwiększenie dokładności odbywa się jednak kosztem szybkości. Dla plików mających bardzo wiele różnic (a szczególnie kompletnie różnych) cała operacja może trwać bardzo długo.


Opcje edytora WAV - Nagrywanie

Ustawienia

Nie używaj wskaźnika poziomu wysterowania w czasie nagrywania
Bardzo wolne komputery mogą wymagać zwolnienia części mocy obliczeniowej procesora zajętej przeliczaniem danych dla wyświetlacza poziomu sygnału.

Próbuj zwalniać pamięć dla nagrywania w pętli
Dla nagrywania w pętli rezerwowana jest część pamięci na bufor dla danych. Windows czasami nie uwalnia jej natychmiast. EAC potrafi wymusić zwolnienie maksymalnej możliwej ilości i przeznaczyć ją dla nagrywania.


Funkcja AccurateRip

Mimo, że EAC gwarantuje poprawne zgrywanie nagrań, zawsze pozostaje jakiś cień niepewności. Można zgraną płytę przesłuchać w całości przed wypaleniem, aby uzyskać pewność, że wszystko jest w porządku. Czy istnieje prostszy sposób? Teraz już tak dzięki projektowi

Jego istota opiera się na założeniu, że jeśli kilkanaście osób zgra tę samą płytę, a sumy kontrolne poszczególnych nagrań będą takie same, to każde kolejne zgranie dające ten sam wynik będzie poprawne. Aby zapewnić powtarzalność wyników należy jednak wyeliminować wszystkie czynniki, które mają na nie wpływ. Jednym z nich jest przesunięcie (offset) wnoszone przez napęd. Dlatego przed przystąpieniem do pracy należy skonfigurować program. Wymagane narzędzia:
  • Kilka ORYGINALNYCH płyt kluczowych z listy, która znajduje się pod adresem http://www.accuraterip.com/keydiscs.htm. Ponieważ ilość wpisów na stronie przekroczyła 20 000 nowe nie są już dodawane - program automatycznie aktualizuje listę płyt kluczowych.

  • Baza danych płyt. Działa na podobnej zasadzie jak np. CDDB. Istnieje także wersja, którą mozna pobrać i zainstalować (najwygodniej będzie umieścić ją w folderze EACa).

  • Bibliotekę, którą należy umieścić w głównym folderze EACa.
Oprócz tego należy dokonać kilku zmian w ustawieniach samego programu:
  • Włączyć opcję 'Nadczytuj w obszarach LeadIn i LeadOut', znajdującą się na karcie 'Przesunięcie/szybkość', menu 'EAC', 'Opcje napędu'
ewentualnie
  • Włączyć opcję 'Uzupełniaj brakujące próbki ciszą' na karcie 'Zgrywanie', menu 'EAC', 'Opcje EAC'a'.
Można włączyć obie powyższe opcje, można tylko jedną z nich. Ale któraś MUSI być włączona (będzie jeszcze o tym mowa dalej).
  • Wyłączyć opcję 'Usuwaj początkowe i końcowe bloki ciszy', znajdującą się na karcie 'Zgrywanie', menu 'EAC', 'Opcje EAC'a'.
To nie wszystko. Problemem może się okazać zgromadzenie odpowiedniej ilości płyt referencyjnych. Nawet tytułów występujących w bazie program może nie rozpoznawać. Chodzi o to, że poszczególne wydania tej samej płyty, lecz tłoczone w różnych tłoczniach, różnią się od siebie dość znacznie. Teoretycznie powinny wystarczyć trzy. W miarę jednak rozwoju projektu i uzupełniania bazy wciąż nowymi danymi, konfiguracja programu przebiega coraz szybciej i sprawniej. Jeśli napęd znajduje się w bazie (lista przetestowanych napędów znajduje się pod adresem www.accuraterip.com/driveoffsets.htm) wystarczy jedna płyta referencyjna.

Po rozpoznaniu płyty przez program pojawi się okienko zachęcające do skonfigurowania funkcji:

Po wybraniu przycisku 'Konfiguruj' program rozpocznie pracę i kilka sekundach poprosi o następną płytę. Po jej włożeniu jeśli wszystko pójdzie dobrze, powyższy komunikat pojawi się ponownie, a następnie zostanie wyświetlony komunikat gratulacyjny - udało się poprawnie skonfigurować program.

Po zgraniu płyty można się przekonać jak to działa:

Co wynika z tego raportu? Trzynaście nagrań zgrało się bezbłędnie i praktycznie można mieć pewność, że nie zawierają przerw, trzasków czy innych artefaktów (gdyż wtedy suma kontrolna byłaby inna). Wiarygodność 3 oznacza, że trzy inne osoby zgrywające nagrania z tej płyty otrzymały identyczne wyniki. Problematyczne jest czternaste nagranie i wymaga uwagi. EAC podaje rodzaj błędu po zakończeniu zgrywania.

Widać, że wystąpił błąd synchronizacji na samym końcu nagrania, ponieważ napęd przesuwa odczyt, a nie potrafi nadczytywać z obszarów LeadIn i LeadOut. Jeśli w 'Opcjach napędu' na karcie 'Przesunięcie/szybkość' wyłączona zostanie opcja 'Nadczytuj w obszarach LeadIn i LeadOut' błąd synchronizacji zniknie, za to może się pojawić inny - za dużo próbek. Poza tym przestanie działać AccurateRip. W tej sytuacji nie pozostaje nic innego, jak wyłączenie opcji nadczytywania i włączenie w 'Opcjach EAC'a' na karcie 'Zgrywanie' opcji 'Uzupełniaj brakujące próbki ciszą'.

To, że AccurateRip działa, a płyta znajduje się w jego bazie danych, można poznać po pojawieniu się po prawej stronie na dole głównego okna EACa, na końcu paska stanu, ikony:

Istotą działania projektu są informacje dostarczane przez użytkowników. Aby przedsięwzięcie się rozwijało należy brać w nim czynny udział. Po wykryciu cech napędu, którego nie ma w bazie danych, trzeba je wysłać. To samo dotyczy wyników zgrywania płyt. Można dane wysyłać na dwa sposoby. Albo za pomocą poczty (elektronicznej) wysłać wygenerowane przez program pliki z danymi, które umieszczane są na pulpicie (po wysłaniu można je usunąć). Albo skorzystać z (zalecanej) opcji 'Internet HTTP'. Gdy zgranej płyty nie ma w bazie danych zostanie podana stosowna informacja:

Aby wysłać wyniki z menu 'Baza danych' na samym dole należy wybrać 'Wyślij wyniki zgrywania do bazy AccurateRip...'.

Otworzy się okno

w którym wystarczy kliknąć przycisk 'Wyśli teraz'. Dane zostaną spakowane i umieszczone na pulpicie w postaci pliku. Trzeba go stamtąd przełożyć do skrzynki i nadać do db@dbpoweramp.com. Albo zostaną od razu przesłane w odpowiednie miejsce, jeśli uaktywniona zostanie opcja wysyłania przez HTTP.


Zasady korzystania z Exact Audio Copy

Exact Audio Copy jest programem typu Cardware, co oznacza, że korzystać z niego można legalnie dopiero po wysłaniu do Autora pocztówki z widokiem okolic miejsca zamieszkania użytkownika na podany poniżej adres. Nie są wykluczone również inne formy wsparcia.

Adresy

Strona domowa programu:
www.exactaudiocopy.de

Kontakt:
webmaster@exactaudiocopy.de

Adres, pod który należy wysłać pocztówkę:

Andre Wiethoff
Am Surck 6
44225 Dortmund
Germany